Not blocking ads. IPV6 issue


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Tests report successful. Ads blocked.

Actual Behaviour:

Test page (https://blockads.fivefilters.org/?pihole) is saying nothing is blocked.
http://ipv6-test.com/ gets 19/20. DNS6 + IP4 Unreachable
I’ve tried reconfiguring with pihole -r but have the same issue still.
I’m using OpenWrt on my router with DHCP-Options pointing to pi-hole’s reserved IPv4 address.

Debug Token:

9hinwsixnb


#2

Are you pushing the IPv6 dns too via dhcp?


#3

I’m not exactly sure how. Every time I put an IPv6 address after the IPv4 in DHCP options, none of my PCs can connect to the network.
I’m really not too familiar with IPv6.

Edit: I’ve added dhcp option 23 with the pi-hole ipv6 address, but still not blocking anything.
http://ipv6-test.com/ is showing 20/20.


#5

Well, it appears to be working now. All ads are being blocked.
I ended up having to ignore or do the opposite of what was instructed on the FAQ.

I set the pi-hole IPs as the DNS server for WAN and WAN6 (not LAN) in OpenWRT, and set OpenDNS as the upstream DNS on the Pi-hole.


#6

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.