Not all devices are connected to Pi-hole

Please follow the below template, it will help us to help you!

Expected Behaviour:

By right all my devices in my network should be going through Pi-hole but it seems like they are not.

Actual Behaviour:

I have set the DNS IP on my WAN router DHCP server. I have verified that the device is pointing to Pi-hole IP address in network properties. However, most devices still unable to resolve using Pi-hole. In the network overview, the devices status is “Not connected”

Debug Token:

https://tricorder.pi-hole.net/b84bih86yg

Welcome to the Pi-hole community, William_Lim. :slight_smile:

From your debug log, your Pi-hole seems to be successfully introduced into your network, with full IPv4 connectivty. It is also positively receiving, blocking and forwarding DNS queries.

However, your Pi-hole machine shows two IPv4 addresses bound to your eth0 interface on two different subnets:

 192.168.1.116/24 
 192.168.218.1/24

If this is by intention, you may have to allow Pi-hole to Listen on all interfaces via its Settings | DNS UI pane.

Note that you may have to additionally configure your router and/or any switch involved to establish valid routes betwen your subnets. You’d have to refer to your network equipment’s documentation on how to achieve this.