"No Internet, secured" on Wi-Fi devices with static IPs when using Pi-Hole DHCP

Expected Behaviour:

All devices connect normally on the first attempt.

Actual Behaviour:

When using Pi-Hole DHCP, my Windows 10 PC and laptop that have static IPs set frequently report “No Internet, secured” on startup or return from sleep, and are not given IP addresses until they disconnect and reconnect to the network.

Debug Token:

https://tricorder.pi-hole.net/71whm9ay8v

When this happens, the affected computers don’t appear to be being assigned IPs at all, according to ipconfig. They are completely unable to connect to the internet in this state, and it is fixed (and they are given the correct IPs) after disconnecting and reconnecting. The issue also disappears when going back to the router’s built-in DHCP; this is specific to when Pi-Hole DHCP is in use. (My ISP’s router doesn’t support using custom DNS, so I have to use Pi-Hole’s DHCP in order to make devices like my Roku stick use it.)

Possibly relevant notes:

  • The msftncsi domains are whitelisted.
  • The static IPs are within DHCP range (should they be set outside of it?)
  • My ISP is AT&T; I’m using their BGW210-700 modem/router with its DHCP disabled. The modem appears to have a second MAC address that keeps showing up as DHCPDISCOVER lines in the logs, I blocked it because it never actually successfully sets an IP just to reduce logspam (if there’s a way to remove the ‘ignored’ lines please tell me); removing this has no effect on the wi-fi connection failure issue.
  • There are other devices on the wi-fi including Windows laptops with no static IP, and an Android phone with a static IP, and none of these are affected; only the two Windows 10 computers with static IPs.
  • I have a 5GHz and 2.4GHz wireless network, but the affected devices only connect to the 5GHz network (so differing 5G/2G MACs aren’t an issue), and other devices on the 5GHz are unaffected.

Disclaimer: I’m just a regular pi-hole user like yourself, and I don’t know anything about Windows.

I gather that you are relying on the dhcp server to give your machines their static ip addresses, is that correct? If so, can you set the ip address on the machine itself?

If Windows clients, check DNS server(s) assigned and DHCP service used with below one:

C:\>ipconfig /all
[..]
Ethernet adapter Local Area Connection:

   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.0.0.11(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : woensdag 28 augustus 2019 15:31:51
   Lease Expires . . . . . . . . . . : donderdag 29 augustus 2019 15:31:51
   Default Gateway . . . . . . . . . : 10.0.0.1
   DHCP Server . . . . . . . . . . . : 10.0.0.2
   DNS Servers . . . . . . . . . . . : 10.0.0.2
   NetBIOS over Tcpip. . . . . . . . : Enabled
[..]

And use the nslookup tool to test (runs on Windows/Linux/MacOS clients):

C:\>nslookup pi.hole 10.0.0.2
Server:  noads.dehakkelaar.nl
Address:  10.0.0.2

Name:    pi.hole
Address:  10.0.0.2

C:\>nslookup pi.hole 8.8.8.8
Server:  dns.google
Address:  8.8.8.8

*** dns.google can't find pi.hole: Non-existent domain

C:\>nslookup pi-hole.net
Server:  noads.dehakkelaar.nl
Address:  10.0.0.2

Non-authoritative answer:
Name:    pi-hole.net
Addresses:  2604:a880:400:d0::1071:1
          206.189.252.21

C:\>nslookup pi-hole.net 8.8.8.8
Server:  dns.google
Address:  8.8.8.8

Non-authoritative answer:
Name:    pi-hole.net
Addresses:  2604:a880:400:d0::1071:1
          206.189.252.21

I did try assigning the static IPs both in the adapter properties and in the connection settings in Windows, but I’ve still been encountering both PCs getting the same “No internet, secured” status, though I haven’t looked at ipconfig when it happened since I made that change, I’ll check next time to see how that’s looking. As for DNS servers, etc.: the last time I did check ipconfig when this happened, it didn’t receive DNS servers either the first time around, then got everything normally after the reconnect.

I’ll post an update the next time I encounter the issue and try to get as much info as I can before I reconnect the wi-fi to fix it (naturally it hasn’t happened yet since I posted this thread).

EDIT: The plot thickens. It happened again, and this time the affected PC does have its assigned IP, it does have DNS servers listed, everything in ipconfig is identical to when it’s working normally, it just… can’t connect to the rest of the network anymore without reconnecting. Signal shows five bars, the router itself still lists it as connected with the correct MAC and IP. It’s not just a DNS issue, either; I can’t even ping other devices on the network by IP.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.