No devices can connect to the internet with Pi-Hole DCHP enabled

I am just having some issues getting DCHP to work and would really appreciate some help.

Expected Behaviour:

Turn off DCHP in BT smart hub 2 and enable it in the PieHole should allow devices to connect to the internet with ads blocked.

Actual Behaviour:

When I have turned off the DCHP setting in my BT smart hub 2 and enabled it in the PieHole no devices can connect to the internet. They cant resolve DNS. I can see devices being assigned IP addresses in the PieHole. I have tried restarting all devices on the network but still no luck.

I have used my PieHole for a while with an older ASUS router but im now in an FTTP house and have to use the BT router at the moment so have no way of using the previous DNS option I used before.

It may be that I am missing something as I have not used DCHP on the PieHole before but ive been around in circles trying to get it working with no avail. Any help would be hugely appreciated. Thank you.

As you say the devices are being assigned IP addresses, make sure that they are able to access Pi-hole and resolve DNS. What is the output of nslookup pi.hole on one of the devices? Is the only DNS in their settings set to Pi-hole?

1 Like

Hi, thank you very much for getting back to me and apologies for my slow reply. Below I have included the results of nslookup before and after changing the DCHP settings. Hopefully it means more to you than it does to me:

With the DCHP set by the router these are the results

C:\Users\Chris>nslookup pi.hole
Server: UnKnown
Address: 192.168.1.254

Non-authoritative answer:
Name: pi.hole
Address: 92.242.132.15

After changing the DCHP to the PieHole these are the results

C:\Users\Chris>nslookup pi.hole
Server: UnKnown
Address: fd9b:894e:ded5:1:b53e:afcf:164a:46c1

DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.
Name: pi.hole
Address: 192.168.1.247

These are the properties for the wifi in windows 10 if that helps:

SSID: ASUS
Protocol: Wi-Fi 5 (802.11ac)
Security type: WPA2-Personal
Network band: 5 GHz
Network channel: 36
IPv6 address: 2a00:23c4:6a9c:6901:f11f:beb3:8e83:b8c4
fd9b:894e:ded5:1::195
fd9b:894e:ded5:1:f11f:beb3:8e83:b8c4
fdcd:484f:6d9:1::195
fdcd:484f:6d9:1:f11f:beb3:8e83:b8c4
Link-local IPv6 address: fe80::f11f:beb3:8e83:b8c4%4
IPv6 DNS servers: fd9b:894e:ded5:1:b53e:afcf:164a:46c1
fdcd:484f:6d9:1:6e30:d88:ae60:cb22
2a00:23c4:6a9c:6901:3a02:becc:607c:ff71
IPv4 address: 192.168.1.208
IPv4 DNS servers: 192.168.1.247
Manufacturer: Broadcom
Description: Dell Wireless 1830 802.11ac
Driver version: 1.566.0.2

Thanks very much for taking the time to help me get this sorted out.

Make sure that you have the correct IPv6 address for the Pi-hole server. The DHCP settings currently use fd9b:894e:ded5:1:b53e:afcf:164a:46c1, but that address does not seem to be working. You may have to use pihole -r to reconfigure the address.

Hi,

I have just checked the PiHole using pihole -r and that PIv6 address is listed as the one to use.

What is the output of ip addr on the Pi-hole server?

With the DCHP enabled in my BT router and off on the PiHole the results of ip addr is:

pi@raspberrypi:~ $ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enxb827eb8e83f8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:8e:83:f8 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.247/24 brd 192.168.1.255 scope global enxb827eb8e83f8
valid_lft forever preferred_lft forever
inet6 fdcd:484f:6d9:1:6e30:d88:ae60:cb22/64 scope global dynamic
valid_lft 7193sec preferred_lft 7193sec
inet6 fd9b:894e:ded5:1:b53e:afcf:164a:46c1/64 scope global dynamic
valid_lft 7093sec preferred_lft 7093sec
inet6 2a00:23c4:6a9c:6901:3a02:becc:607c:ff71/64 scope global dynamic
valid_lft 288sec preferred_lft 108sec
inet6 fe80::e585:a7f8:4b44:fc15/64 scope link
valid_lft forever preferred_lft forever
3: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
link/none
inet 10.8.0.1/24 brd 10.8.0.255 scope global tun0
valid_lft forever preferred_lft forever

You have a network issue preventing your devices from reaching the Pi-hole server over fd9b:894e:ded5:1:b53e:afcf:164a:46c1. Either use a different IPv6 address that the other devices can use, or fix the issue.

Hi, apologies for asking what may be obvious but what is the way to use a different IPv6 address or fix the current one?

Thanks

Try editing /etc/pihole/setupVars.conf and change the value of IPV6_ADDRESS to a reachable IPv6 address. Then run pihole -r to repair.

Fixing the current one means routing requests to that address to your Pi-hole server (right now the requests are not making it to Pi-hole). This depends upon how you set up your network, and is beyond the scope of Pi-hole.

I accessed the PiHole through PuTTY tried editing the setupVars. I keep getting access denied even though I have logged in as the main user.

I have also just checked the PiHole though the web interface and gone into settings then system. There is an IPv4 address listed there but the IPv6 is showing no address at all.

Edit files with nano as superuser: sudo nano [filename]

Thanks for the help on getting to the point where I can edit the setupVars.conf. I’ve had a look and IPV6_ADDRESS= shows nothing beside it. If I type in the ipv6 address I want to use how do I then save this?

Thanks

A post was split to a new topic: Skype mic not working

I have typed in the IPv6 address to use but then I am not sure how to get this to save the change. Thanks for any help

@rollac01

save the changes with
Ctrl. + O
Then ENTER
then Ctrl. + X