New PiHole setup not blocking ads

Expected Behaviour:

Blocks ads

Actual Behaviour:

No ads being blocked

Debug Token:

https://tricorder.pi-hole.net/vp98jyf0ok

I have spectrum, and their router. I can’t manually set the ip for DNS server but I turned off DHCP for the router and enabled it on the pi.

I tried to read through similar posts but was unable to figure out what I needed to do differently. I followed this website exactly: https://blog.cryptoaustralia.org.au/instructions-for-setting-up-pi-hole/

After that, I added a bunch of blocklists recommended on this site and reddit, and then added some common whitelists as well.

I restarted my computer and phone which are the devices I’m using to test. Mostly I’m going to sites I know have a lot of ads, and on my admin page for the pihole I see that I have new leases for these devices

Fyi, I’m somewhat tech savvy but completely new to using a pi

Maybe your clients are still using the old lease (from the router) and that’s why they don’t show blocked ads.

Try release/renew and even a nslookup flurry.com see what DNS those requests are going through …

Hi RamSet,

Thanks for your quick response. I did restart all devices I’m testing with and confirmed they have a lease through the pihole.

I did the nslookup you suggested and this is what I got: (in pic attached)

Well then, there’s your answer :slight_smile:

Your charter provided router is taking over the DNS requests.

Also they seem to be resolving via IPV6 which is another thing you need to look into.

Thanks for being so responsive. Please forgive my ignorance, I am trying to learn quickly.

Is there something I can do about the current router taking over the DNS requests besides buying a new router?

Also, I’m not sure if this is helpful re: your second note, but I have “Enable IPv6 support (SLAAC + RA)” enabled on my pihole admin page.

You should see if it has something like DNS rebind in the settings and disable that …

OR see if it allows you to change the IPV4 DNS IP on the WAN side top the IP of the raspberry.

That is all good however the IPV6 setup is a little bit (tricky and more) advanced.

You need to specify the IPV6 DNS server in the Router to the IPV6 IP of the Pi and enable a more stable solution for IPV6 on the raspberry so that it does not change.

Quite a bit more complex though … You can (and should) disable IPV6 support within your network as it has no real benefit within a LAN.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.