New install of 3.3 doesn't seem to be actually filtereing

v3-3
#1

I used to run an older version of pi-hole with great success. I had to rebuild after my SD card failed (it was my own fault, I had a dirty shutdown) and decided to use the latest and greatest.

Nothing else has changed for me: I re-used the static IP address of the pi-hole
My DHCP scope is using the pi-hole as the DNS
Clients show the proper address for DNS server in ipconfig /all

Expected Behaviour:

Pi-hole blocking a ton of ads.

Actual Behaviour:

My problem is that while the logs appear to show ads being blocked, I still see all the ads. For example, if I disable pi-hole, open an incognito browser to a site and then re-enable the pi-hole, flush dns, and open an incognito browser to the same site – I get the same thing! https://www.detectadblock.com/ says I’m allowing ads. I even tried switching off my DHCP server on my firewall and used the pi-hole DHCP server to no avail. Thanks in advance to anyone with ideas.

Debug Token:

6s7ugk03fo

0 Likes

#2

Take a look here
A solution is downgrading your version as i did.

0 Likes

#3

According to your debug log, you have already upgraded dnsmasq–hopefully per this:

you’re still on Jessie, which doesn’t work with Pi-hole v3.3.

So I would ask that you please run a pihole -r > Repair and let me know if that resolves the issue.

0 Likes

#4

I ran through the repair and it hasn’t changed anything. Is downgrading a better option than trying to work through this, or do you know if an update may be coming forth soon? Thank you for your help.

0 Likes

#5

FLTDNS™ will be released Soon™.

0 Likes

closed #6

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes