Network drops when using Youtube

Setup:

Modem wired to Router
Router DHCP disabled
Pi-Hole running on Pi-Zero

DNS:

127.0.0.1#5335 on IPv4 only
Recommended Setting enabled

Expected Behaviour:

Network stays connected

Actual Behaviour:

I've noticed specifically when watching Youtube, the network will drop across all devices, WIFI stays connected.

If I'm patient, it returns, only to drop again after a few minutes.

Restarting the DNS resolver also fixes the issue temporarily.

Debug Token:

https://tricorder.pi-hole.net/nVr1kNj7/

@morethan1 You pi may be getting overloaded, make sure you use a 2-3a power supply and that the pi isn't overheating

Power supply: 5.1V 2500mA

nobody?

Please upload a fresh debug log and post the token URL.

debug token updated

You have a configuration problem. The wlan0 interface is at one IP, and Pi-hole is configured for a different IP (not even on the same range).

*** [ DIAGNOSING ]: Network routing table
   default via 192.168.1.1 dev wlan0 
   192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.106 

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] inpost-polska-car.orders091.info is 0.0.0.0 on lo (127.0.0.1)
[✓] inpost-polska-car.orders091.info is 0.0.0.0 on wlan0 (192.168.1.106)
[✓] doubleclick.com is 172.217.13.174 via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Setup variables
    ...
    PIHOLE_INTERFACE=wlan0
    IPV4_ADDRESS=192.168.0.18/24

First, ensure that your IP on the wlan0 is static on the Pi. This is usually set in file /etc/dhcpcd.conf.

Second, run pihole -r and select the reconfigure option to set up Pi-hole on the correct IP.

Your DHCP server is passing out Cloudflare as DNS in addition to your local DNS server. This allows clients to bypass Pi-hole at any time. Remove the Cloudflare entry.

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   
   * Received 548 bytes from wlan0:192.168.1.1
     Offered IP address: 192.168.1.106
     Server IP address: N/A
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.1.1
      lease-time: Infinite
      netmask: 255.255.255.0
      router: 192.168.1.1
      dns-server: 192.168.1.106
      dns-server: 1.1.1.1
      --- end of options ---
    
   DHCP packets received on interface wlan0: 1
   DHCP packets received on interface lo: 0

Other observations from your debug log:

This regex entry will not be effective, because http is not part of a domain name (it is part of a URL).

(\.|^)http://get-express-vpn\.online$

Two of your subscribed adlists do not appear to be available on the internet any longer:

  [i] Target: https://mirror1.malwaredomains.com/files/justdomains
  [✗] Status: Not found
  [✗] List download failed: no cached list available

...

  [i] Target: https://hosts-file.net/ad_servers.txt
  [✗] Status: Not found
  [✗] List download failed: no cached list available

Thanks for the thorough feedback :hugs:. I've made the changes. Let's see how I fair.

I also noticed that I do NOT have DHCP running on the pi-hole rather still on my router.

1 Like

I'm still experiencing periodic drops.

Here's the new debug token:

https://tricorder.pi-hole.net/Getlupni/

Missed one.

(\.|^)http://get-express-vpn\.online$

Your debug log is normal.

It's very odd... when my mac awakes from sleep, it connects to the wifi but no network. My other devices are fine.

Sleep and wake the Mac, then check your MacOS DNS settings in System Preferences.

192.168.1.106

The network drops are getting worse and random. Not sure what to check short of removing pi-hole.

If your other devices are fine, then the problem likely lies outside of Pi-hole. I would visit the Mac forums.

Curious, when I shutdown the pi-hole, all is well...

Manually assign a different DNS server for the Mac if that's what is needed to keep the Mac on the network.

will try, thanks!