Nach Update (4.1): DNS nur nach manuellen Starten


#1

Irgendwie hasst mich pihole :frowning:
kann doch echt nicht so schwer sein oder?
Hin und wieder ein sudo apt-get update/upgrade - und wenn eine neue Version kommt pihole -up. Mehr mach ich mit dem drecksding nicht …

und dann passiert das was schon bei 4.0 passierte (wo ich dann pihole aus frust komplett neu installiert hatte… also mit unterbau … um sämtliche altlasten zu vermeiden) … nach dem update … nein während des Updates wundert sich pihole das DNS nicht funktioniert - das update schlägt fehlt …

sudo pihole-FTL
und DNS läuft wieder … Laut WebGUI ist alles auf 4.1 … ein restart DNS oder restart des pis => DNS wieder offline … ich muss manuell starten. Ich starte pihole -up … es erfolgt wieder ein update von FTL (obwohl 4.1 doch drauf ist). … ok und wieder wird erst DNS deaktiviert um dann festzustellen das kein DNS verfügbar ist…

Dann lese ich das ich mal in der /etc/resolv.conf die 8.8.8.8 setzen soll. Gemacht … nach reboot allerdings weg … ok mach ich dann direkt vor dem pihole -up … aber nein auch das funktioniert nicht. Nach reboot muss ich ftl wieder händisch starten …

Was mache ich den falsch das ich ständig update-probleme mit pihole habe?! :frowning:


#2

jetzt gab es das update auf 4.1.1 … das Verhalten das sich das Update (und auch repair) selber den DNS abschießt bleibt bestehen :frowning:

In die /etc/resolv.conf die 8.8.8.8 eintragen und das -up bzw. -r starten hilft auch nicht. DNS wird vom Setup gekillt und danach heißt es: kein DNS -> fail. Ich muss über eine zweite Session sudo pihole-FTL starten damit das Setup zu ende läuft und ich wieder DNS habe. Reboot => DNS tot.