Max2play on rpi doesnt like pi-hole?

my rpi currently runs max2play to stream mp3 to other rpi as seen here: FAQs | Max2Play

i just installed pi-hole on the same rpi and i can never log into the pi-hole admin page.
ip address is so the admin page gives 404 error. if i type in a browser, i do get default apache page, i think.
yes, i rebooted the rpi several times too.
anywho, i changed my house's router to DNS server of ads are still being served on desktops and mobile devices.
any advice?

Sounds like you have another webserver running on that port. Can you run pihole -d and get us the output of the debug run?

pi@max2play:~ $ pihole -d
-bash: pihole: command not found

i ran the installation again just to be sure:
curl -L | bash

choose an interface for my wired cat5 to rpi: etho0
select protocol: ipv4
do u want current network settings as static? yes
next screen doesnt have instructions, just a list of 6 DNS? i chose Google

back to terminal: The install log is located at: /etc/pihole/install.log
::: View the web interface at http://pi.hole/admin or
pi@max2play:~ $

Does ls -lah /opt/pihole/ or ls -lah /usr/local/bin/ return any values?


pi@max2play:~ $ ls -lah /opt/pihole/
total 8.0K
drwxr-xr-x  2 root root 4.0K Oct 26 01:13 .
drwxr-xr-x 11 root root 4.0K Oct 26 01:13 ..
pi@max2play:~ $ ls -lah /usr/local/bin/
total 368K
drwxrwsr-x  2 root staff 4.0K Jul  6 16:36 .
drwxrwsr-x 10 root staff 4.0K Feb  9  2016 ..
lrwxrwxrwx  1 root staff   12 Jul  6 16:36 luajit -> luajit-2.0.4
-rwxr-xr-x  1 root staff 360K Jul  6 16:36 luajit-2.0.4

You are missing all of the Pi-hole files. Can you post a copy of the setup log file?

im new to rpi. i will assume this is what you mean?
pi@max2play:~ $ sudo nano /etc/pihole/install.log

::: Checking if user 'pihole' exists...
::: User 'pihole' already exists
::: Installing scripts to /opt/pihole...

btw, this is the only command i ran as seen from the front page of pi hole:
curl -L | bash

that seems to automatically update/intalll things on its own.

I've just read through the documentation for Max2Play and it doesn't look like we're able to support that platform. They use a custom image and their own webserver that would conflict with the Pi-hole requirements. Sorry.

oh ok. thanks a lot for your time!
i guess since pi hole was not installed properly, then i dont have to run any command to uninstall then?
i will try another rpi thats currently working as a NAS in the house.

Correct, there's no files to remove from your installation. You may want to delete the pihole user that looks like it was added before the installation failed.

Let us know if you have any issues with the NASberry install.

Can we run Soundcloud also at IP?