Make pihole-FTL bind only on certain IPs [v4.0]

Try the "listen-address=" directive:

pi@noads:~ $ man dnsmasq
  -a, --listen-address=<ipaddr>
        Listen on the given IP address(es). Both --interface and  --lis‐
        ten-address  options may be given, in which case the set of both
        interfaces and addresses is used. Note that  if  no  --interface
        option is given, but --listen-address is, dnsmasq will not auto‐
        matically listen on the loopback interface. To achieve this, its
        IP  address,, must be explicitly given as a --listen-
        address option.


You can put that directive in a new dnsmasq config file that will be read by pihole-FTL:

sudo nano /etc/dnsmasq.d/99-my-settings.conf