Lost Internet After Adding Unbound to Pi-hole


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi-hole to continue to block ads and not block the whole internet after adding unbound.

Actual Behaviour:

Pi-hole was blocking ads as expected until I installed and implemented unbound, then I was unable to access the internet. I installed pi-hole from a docker onto an odroid xu4 using openmediavault.

Debug Token:

https://tricorder.pi-hole.net/2084jk84dv!


#2

“installed pi-hole from a docker onto an odroid xu4 using openmediavault.” .

I’m definitely not a pi-hole expert, but that sounds like a recipe for trouble. And, as no one else has commented,

Why didn’t you just use the standard/documented installation process :

curl -sSL https://install.pi-hole.net | bash

on your Odroid? It has worked for me with 2 versions of Linux.

Good luck!


#3

Thanks for the suggestion. I will consider it if no one else responds. Could I install it using Ubuntu 16? I have run that before on the Odroid.
I just figured it was some kind of a wrong setting on my Tomato router, as pihole + unbound works fine when I just set one client alone to the pihole dns resolver.


#4

The problem beforef pi-hole V4 was that it would try to use whatever version of dnsmasq was already installed (V16 ubuntu seemed to be OK, based on what I have read here in other threads). Now, pi-hole maintains and uses it own special version of dnsmasq (If I understand what I have read correctly :wink: ).

As far as unbound, sorry my reading hasn’t taken me that far yet.

From my experience as a programmer, it’s better to get one basic system (pi-hole) to work as promised, and then start adding on more features.

Good luck!


#5

This is a supported configuration.

https://docs.pi-hole.net/ftldns/compatibility/

https://docs.pi-hole.net/main/prerequesites/