Losing conection to Internet

Please follow the below template, it will help us to help you!

Expected Behaviour:

[Pi-hole running with internet connection]

Actual Behaviour:

[Pi-hole or the router loose the internet connection]

Debug Token:

[I run pihole -d but give me an error when try to upload the log]

Hi mates!

I have problems with the Pi-hole and my router.

The router it’s the one that my ISP give with the contract. It’s an Arcadyan VRV9518 with the ISP configurations.

I’ve already install and setup (3 fresh installs and counting!) Pi-Hole on a Raspberry Pi 3.

The problem comes when unplug the Pi from the power. When I turn on again, it crash my Internet conection.

This is the Device List of my router:


The 4th position is the Pi, with the DHCP mode and the IP set.

Then I go to the LAN section, and change the “DNS IP Adress” to “Manual” and enter the PI-hole IP (192.168.1.17) and save the changes.


I do not modify anything (DHCP Server and IGMP Snooping(¿?) are ticked automatically) Lease Time remains in 1 day.
After that, I go to the LAN DHCP settings, and add the MAC and IP of the Pihole.

With that, Pi-hole start working like a charm! Start blocking ads right away.

The problem comes when I turn down the Raspberry: I loose Internet connection and have to disable the Manual DNS IP Adress to get internet running.
And in the device list, the Raspberry changes the name to PC192-168-1-17 and the mode to STATIC.

I’m missing some configuration? Or is the router causing troubles?

Sorry for my english, I hope I have made myself clear.

Regards!

This will temporarily reset the nameserver on the Pi to bypass Pi-Hole DNS.

sudo nano /etc/resolv.conf

edit nameserver 127.0.0.1 to nameserver 9.9.9.9 or your preferred third party DNS service, save and exit

Run pihole -d and upload the debug log

Thanks for the reply JFB! It work great!

Here are the token: https://tricorder.pi-hole.net/u334y181i2

Hope this help…

The Pi must stay running 24/7 if it is your DNS server - do not turn it on and off.

It’s hard to explaing, but here we go.

I’m setting up the Pi in the living room with a TV and the Ethernet port in the wall, after that, I have to take the Pi to the middle of the house, where the router is.
Thats it’s why I turn it off.
Also already try leaving it plugged in, and it ends up happening what I described above.

My idea it’s to leave it 24/7 right to the router with the 3.5 LCD Screen showing stats…

Nothing yet? Any solution?

I’ve had similar-ish issues… full disclosure I’m a novice w/ Pihole and Linux, and some of these steps are likely unnecessary and/or inefficient but worth a try.

Maybe disconnect the ethernet cable for this, maybe.

  • Try clearing all your IP settings

  • Confirm no IP settings: cat /etc/network/interfaces and via the GUI (if possible)

  • Reboot the pi/interface to confirm no IPs.

  • Set the IP statically

  • Reconnect cable and confirm connectivity

  • pihole -r to reconfigure

  • Remove cable/reboot.

  • Confirm static config and if IP is present move Pi.

Are you moving your Pi-hole because you are using your TV as a screen while configuring Pi-hole?

If so, try placing your Pi-hole where you’d ultimately want it straight away and configure it remotely via ssh from your PC.

New fresh install with another guide an the Pi in place.

Let’s wait to tomorrow and see if take down the internet connection…

Thanks for the reply!