Lighttpd daemon is failed

Please follow the below template, it will help us to help you!

Expected Behaviour:

[lighttpd should be running on the provided port 8093]

Actual Behaviour:

[lighttpd exits]

Debug Token:

[https://tricorder.pi-hole.net/18jv2nw389!]

I noticed I could no longer connect to the admin page. The last time I connected was when I updated. I added the port I have always used (8093) in the etc\lighttpd\external.conf. When that did not work I changed it in etc\lighttpd\lighttpd.conf. That doesn’t do the trick as well. Pi hole is working, but I cannot access it. Apache is running port 80 btw, but I assumed changing the admin port of pi-hole to 8093 would fix that problem. I am at the end of my very limited knowledge…
thx for any help.

What URL are you using to access the web interface?

You do have lighttpd configured on port 8093, per your debug log, in file /etc/lighttpd/lighttpd.conf. But, the debug log is also showing it running on port 80.

What are the contents of /etc/lighttpd/external.conf

And output of sudo netstat -nltup

I’m using http://192.168.8.156:8093/admin/ a bookmark i’m using some years. I have some other things running there (Domoticz) and I have no problem accessing that (port 8080).

/etc/lighttpd/external.conf contains only one line:

server.port = 8093

sudo netstat -nltup returns:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      757/pihole-FTL      
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      685/sshd            
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      410/cupsd           
tcp        0      0 0.0.0.0:1883            0.0.0.0:*               LISTEN      792/mosquitto       
tcp        0      0 0.0.0.0:548             0.0.0.0:*               LISTEN      531/afpd            
tcp        0      0 127.0.0.1:4711          0.0.0.0:*               LISTEN      757/pihole-FTL      
tcp6       0      0 :::8080                 :::*                    LISTEN      852/domoticz        
tcp6       0      0 :::53                   :::*                    LISTEN      757/pihole-FTL      
tcp6       0      0 :::22                   :::*                    LISTEN      685/sshd            
tcp6       0      0 ::1:631                 :::*                    LISTEN      410/cupsd           
tcp6       0      0 :::443                  :::*                    LISTEN      852/domoticz        
tcp6       0      0 :::1883                 :::*                    LISTEN      792/mosquitto       
tcp6       0      0 ::1:4700                :::*                    LISTEN      508/cnid_metad      
tcp6       0      0 :::6144                 :::*                    LISTEN      852/domoticz        
tcp6       0      0 ::1:4711                :::*                    LISTEN      757/pihole-FTL      
udp        0      0 0.0.0.0:1900            0.0.0.0:*                           800/minissdpd       
udp        0      0 0.0.0.0:53              0.0.0.0:*                           757/pihole-FTL      
udp        0      0 0.0.0.0:67              0.0.0.0:*                           757/pihole-FTL      
udp        0      0 0.0.0.0:68              0.0.0.0:*                           677/dhcpcd          
udp        0      0 0.0.0.0:631             0.0.0.0:*                           412/cups-browsed    
udp        0      0 0.0.0.0:33445           0.0.0.0:*                           343/avahi-daemon: r 
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           343/avahi-daemon: r 
udp6       0      0 :::53                   :::*                                757/pihole-FTL      
udp6       0      0 :::44101                :::*                                343/avahi-daemon: r 
udp6       0      0 :::5353                 :::*                                343/avahi-daemon: r

I don’t see any web servers running on port 80. Perhaps some conflict with other software is keeping them from launching.

external.conf can not change the port, so remove that line in case it is causing issues.

@jfb ; Correct, I forgot that I disable Apache to see if that was a problem. I reenabled it again.
@Mcat12 ; Ok, I removed that line from external.conf (it is empty again) and changed the port number to 8093 in lighttpb.conf

I rebooted after those changes, and it is working again. I don’t understand it, but I’m happy. Thank you for your responses.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.