Landing Page is not working


#1

Expected Behaviour:

Show blocked landing page

Actual Behaviour:

Nothing shows up

Debug Token:

feh1qdbpcr

I have my PiHole setup on Google Instance and everything works fine except the landing page.

It will block the query but in the browser the page doesn’t go to any landing page and just showing the IP couldn’t get resolve.

Do you have to enable any setting or I’m doing something wrong in here?


#2

This is a change in V4. In earlier versions, the default blocking mode was IP, which returned the IP address of the Pi-Hole. The new default is NULL (as explained in the linked article) as the developers found that NULL provided the best performance for the majority of users.

https://docs.pi-hole.net/ftldns/blockingmode/

Changing your default blocking mode is discussed in this link.

https://docs.pi-hole.net/ftldns/configfile/


#3

Thanks for the info.

So I did the BLOCKINGMODE=IP-NODATA-AAAA but the result point to the local IP address instead of the public address and I’m not sure how to change that.


#4

I don’t fully understand the problem. Can you post a screen snap of what you are seeing?


#5

Sure,

So on the VM I have public IP address is 35.196.128.121 and local IP address is 10.142.0.2

image


#7

Have flushed the DNS cache with ipconfig /flushdns in a dosbox and restarted the browser?


#8

Still same result and it’s point to the internal IP address.

Do I need to change anything in the VM ?


#9

Add or change to in your /etc/pihole/setupVars.conf the

IPV4_ADDRESS=35.196.128.121


#10

Thanks, that worked