LAN IP DNS Resolution

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Conditional forwarding sends reverse lookups to my OpenWRT router on 192.168.0.1 and the dashboard and logfiles display the name of the host instead of the IP.

Actual Behaviour:

Conditional forward is sending the reverse lookups, confirmed through syslog entries by dnsmasq on OpenWRT that show it is returning DNS names, but they are not appearing in the dashboard or history.

Debug Token:

https://tricorder.pi-hole.net/7pg2f8aedr!

I recently upgraded my Dockerhub container to the latest version ( Pi-hole Version v4.2.2 Web Interface Version v4.2 FTL Version v4.2.3) and also switched to host networking mode for docker. I do not use pi-hole for DHCP service. The only changes to my docker configuration were that I removed the “–dns=127.0.0.1 --dns=1.1.1.1” line to set dns resolvers and a “–net=host”.

For the most part things are working, except none of the hostnames are showing up in the log. I checked my router and I see the reverse lookups coming in and getting resolved into the .lan hostnames, but I do not see the hostnames in the pi-hole dashboard or log. Does anyone have any idea what might be going on? This worked before the upgrade and now I only see the IP addresses.

#4

I checked my router and I see the reverse lookups coming in and getting resolved into the .lan hostnames

Try setting your router as one of your upstreams perhaps.

the web interface uses whatever the container has in it’s /etc/resolv (docker exec pihole cat /etc/resolv.conf) which is controlled by the --dns settings you removed.

Removing the 127.0.0.1 will sometimes break the startup gravity process too. Getting LAN DHCP hostnames working from the router can be tricky because of this fact.

#5

Thanks for that hint! I modified my linux host’s /etc/resolv.conf to add the 127.0.0.1 and 1.1.1.1 DNS since I switched to host networking on the container and redeployed the container. It took those settings for its local resolv.conf and now .lan hostnames are reverse resolving again.