Is Pi-Hole blocking properly?


#1

Expected Behaviour:

Ads should be blocked and so should blacklisted domains

Actual Behaviour:

Nothing seems to be blocked.

For reference I’ve tried adjusting my DNS settings so that traffic is only being routed to the IP of my pi (I made sure that there are no other IPs). When that didn’t work I tried setting the pi as my DHCP server after turning of DHCP on my router and this doesn’t seem to work either.

When I look in the Pi-hole dashboard it’s definitely capturing a ton of data but nothing actually seems to be working.

Debug Token:

mrr76br3ss


#5

What is the output of this command - reads the stats from your Pi-Hole:

echo ">stats" | nc localhost 4711

Then run the following to restart pihole-FTL:

sudo service pihole-FTL restart


#6

I think the blacklist is actually working now, maybe the DNS settings were taking a while to propagate!

Here’s the output of that command anyway:

domains_being_blocked 608855
dns_queries_today 7418
ads_blocked_today 2088
ads_percentage_today 28.147749
unique_domains 1147
queries_forwarded 4728
queries_cached 602
clients_ever_seen 13
unique_clients 13
dns_queries_all_types 7912
reply_NODATA 70
reply_NXDOMAIN 51
reply_CNAME 2473
reply_IP 5854
status enabled
—EOM—

I don’t think a lot of ads are being blocked but, from what I can tell, it may be because those ads are being served by the same domain as the app etc.


#7

From your data shown, 28% of the DNS queries are being blocked. Not all of those contain ads (some could be metrics, tracking sites, etc.).

This may help you track down the source of the ads you are seeing:

Note that after you change your DHCP server you typically need to re-connect clients to get the updated DNS information to them, or wait until the lease renews (typically 24 hours).


#8

Cheers for the info, that’s very helpful! Much appreciated!