Is Debian Buster now an officially supported platform?

Hi,

I am following this closely and I spotted Getting ready for Buster that it works now on “Buster”.
But when checking the list of supported operating systems on https://docs.pi-hole.net/main/prerequesites/#supported-operating-systems Buster isn’t listed yet.

Can you clarify please?

Regards

Tom

The docs haven’t been updated yet.

New to pi hole, but have been running squid proxy for ad blocking, dnsmasq for DNS caching, all over OpenVPN. Now replacing dnsmasq with pi hole. Anyway, Raspbian Buster install works great as documented in the supported platforms. Tried Debian Buster, but fails on FTL DNS install.

Here’s the output:

  [i] FTL Checks...

  [✓] Detected 32bit (i686) architecture
  [i] Checking for existing FTL binary...
  [✗] Downloading and Installing FTL
  Error: Unable to get latest release location from GitHub
  [✗] FTL Engine not installed

Ok, figured this out… installing over an existing system with dnsmasq already running was somehow preventing it from properly resolving github.com, which is why the latesttag varible wasn’t getting set and erroring out. Updated /etc/resolv.conf to get DNS resolution working.