IPv6 domains not blocked?

Please follow the below template, it will help us to help you!

Expected Behaviour:

Domains on the block list should be blocked even over IPv6.
I have full IPv6 connectivity to the internet and my PI Hole (which is working wonderfully for IPv4 thank you) is not blocking domains over IPv6.

Actual Behaviour:

Resolving www.google-analytics.com I get two entries in the query log IPv4 says Pi-holed IPv6 says OK (forwarded).
I have run pihole -r again to ensure both IPv4 and IPv6 blocking is enabled.
I have also ran sudo apt-get upgrade to ensure I am running the latest version of Raspbian Jesse Lite.

Debug Token:


Thank You!

I'm assuming this FAQ does not apply as I do in fact want FTL to analyse AAAA queries as my internet connection is IPv6 enabled?


You're probably encountering a current bug in how we generate gravity.list. Your IPv6 address in /etc/pihole/setupVars.conf includes the /64 at the end, which we are not accounting for when generating gravity. This leads to invalid entries, which are ignored, effectively removing any IPv6 blocking. Remove the /64 from the end of your IPv6 address in setupVars.conf and run pihole -g. This will be fixed in the next release.

1 Like

Hi Mcat12,

This worked immediately! Thanks for your help :smile: