IPv6 address question

Your output shows that dig was using your router as DNS server.

Please repeat the commands, forcing lookup through your Pi-hole's IP this time:

dig -x <your-ipv6-address-here> @192.168.1.88
PS: (click for more)

Please consider posting the textual output of commands.
It might be necessary to reenact or reuse some of it, and that is easier to do for both other potential readers and me with living text instead of a “ dead ” screenshot.

You can paste your output here and format it by selecting a text passage and applying the </> Preformatted text option from the menu. :wink:

PPS:
In some shells (e.g. puTTY) it is enough to highlight text to copy it into the clipboard, from where it can be pasted here.

1 Like

I thought about posting the text but it looks off/not formatted for easy reading..

pi@raspberrypi:~ $ dig -x 2001:8a0:574c:e301:30a0:4f96:b62b:c768@192.168.1.88                                                                                                                                                                                                                         ; <<>> DiG 9.11.5-P4-5.1+deb10u1-Raspbian <<>> -x 2001:8a0:574c:e301:30a0:4f96:b62b:c768@192.168.1.88                                              ;; global options: +cmd                                                                                                                            ;; Got answer:                                                                                                                                     ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 46842                                                                                         ;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1                                                                                                                                                                                                                               ;; OPT PSEUDOSECTION:                                                                                                                              ; EDNS: version: 0, flags:; udp: 4010                                                                                                              ;; QUESTION SECTION:                                                                                                                               ;88.1.168.2001:8a0:574c:e301:30a0:4f96:b62b:c768\@192.in-addr.arpa. IN PTR                                                                                                                                                                                                                            ;; AUTHORITY SECTION:                                                                                                                              in-addr.arpa.           2391    IN      SOA     b.in-addr-servers.arpa. nstld.iana.org. 2020061019 1800 900 604800 3600                                                                                                                                                                               ;; Query time: 156 msec                                                                                                                            ;; SERVER: 192.168.1.254#53(192.168.1.254)                                                                                                         ;; WHEN: ter jun 30 12:31:55 WEST 2020                                                                                                             ;; MSG SIZE  rcvd: 161  
                                                                                                                                                                                                                                                                              pi@raspberrypi:~ $ dig -x 2001:8a0:574c:e301:4d99:d1e0:7c76:4db3@192.168.1.88                                                                                                                                                                                                                         ; <<>> DiG 9.11.5-P4-5.1+deb10u1-Raspbian <<>> -x 2001:8a0:574c:e301:4d99:d1e0:7c76:4db3@192.168.1.88                                              ;; global options: +cmd                                                                                                                            ;; Got answer:                                                                                                                                     ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40517                                                                                         ;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1                                                                                                                                                                                                                               ;; OPT PSEUDOSECTION:                                                                                                                              ; EDNS: version: 0, flags:; udp: 4010                                                                                                              ;; QUESTION SECTION:                                                                                                                               ;88.1.168.2001:8a0:574c:e301:4d99:d1e0:7c76:4db3\@192.in-addr.arpa. IN PTR                                                                                                                                                                                                                            ;; AUTHORITY SECTION:                                                                                                                              in-addr.arpa.           1717    IN      SOA     b.in-addr-servers.arpa. nstld.iana.org. 2020061019 1800 900 604800 3600                                                                                                                                                                               ;; Query time: 212 msec                                                                                                                            ;; SERVER: 192.168.1.254#53(192.168.1.254)                                                                                                         ;; WHEN: ter jun 30 12:35:51 WEST 2020                                                                                                             ;; MSG SIZE  rcvd: 161

Also I checked on the router again and DHCP is off.Screenshot_1

You missed a (significant) space between address and the server.
(:c768@192. vs. correct :c768 @192.)

1 Like
pi@raspberrypi:~ $ dig -x 2001:8a0:574c:e301:30a0:4f96:b62b:c768 @192.168.1.88

; <<>> DiG 9.11.5-P4-5.1+deb10u1-Raspbian <<>> -x 2001:8a0:574c:e301:30a0:4f96:b62b:c768 @192.168.1.88
;; global options: +cmd
;; Got answer:         
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 57727 
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1     

;; OPT PSEUDOSECTION:  
; EDNS: version: 0, flags:; udp: 1452      

;; QUESTION SECTION:   
;8.6.7.c.b.2.6.b.6.9.f.4.0.a.0.3.1.0.3.e.c.4.7.5.0.a.8.0.1.0.0.2.ip6.arpa. IN PTR

;; Query time: 4623 msec   
;; SERVER: 192.168.1.88#53(192.168.1.88)   
;; WHEN: ter jun 30 13:06:25 WEST 2020     
;; MSG SIZE  rcvd: 101      
pi@raspberrypi:~ $ dig -x 2001:8a0:574c:e301:4d99:d1e0:7c76:4db3 @192.168.1.88   

; <<>> DiG 9.11.5-P4-5.1+deb10u1-Raspbian <<>> -x 2001:8a0:574c:e301:4d99:d1e0:7c76:4db3 @192.168.1.88     
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44764  
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1  

;; OPT PSEUDOSECTION:  ; EDNS: version: 0, flags:; udp: 4096      

;; QUESTION SECTION:   ;3.b.d.4.6.7.c.7.0.e.1.d.9.9.d.4.1.0.3.e.c.4.7.5.0.a.8.0.1.0.0.2.ip6.arpa. IN PTR

;; ANSWER SECTION: 
3.b.d.4.6.7.c.7.0.e.1.d.9.9.d.4.1.0.3.e.c.4.7.5.0.a.8.0.1.0.0.2.ip6.arpa. 2 IN PTR raspberrypi.  

;; Query time: 1 msec  
;; SERVER: 192.168.1.88#53(192.168.1.88)   
;; WHEN: ter jun 30 13:06:38 WEST 2020     
;; MSG SIZE  rcvd: 126

From what I understood, c768 doesn't return the hostname while 4db3 returns the raspberrypi, as it should.

Yes. But you could have two. Pi-hole cannot know this. Someone told it that this IP has the host name raspberrypi

That's correct, and from that output, we can conclude that Pi-hole does not associate your mobile phone's :c768 address with a hostname of raspberrypi.

Rather, there seems to be no hostname at all associated with your mobile, which is unusual. Most mobile phones will also try to register a name when requesting an IPv4 address via DHCP. IPv6 addresses get associated with that hostname by virtue of using the same MAC on the link, at least when Pi-hole is acting as DHCP (which it is in your case, right?).

Does your mobile phone appear with a DHCP lease under Settings | DHCP ?

1 Like

Only the IPv4 of the phone shows up there. Strange.
Is there a way to flush all the leases or restart the DHCP to gather the devices again?
I'm considering turning off IPv6 on DHCP after all this...

PS.- Thank you so much for helping me Bucking_Horn

That's ok.
Devices are not at all obliged to request an IPv6 address via DHCPv6. In fact, most won't (Android doesn't even support DHCPv6). Commonly, they will calculate an IPv6 address for themselves, respecting only some information as advertised by the router via RAs (most importantly, the IPv6 prefix),

But if an IPv4 DHCP lease would have been absent for your Smartphone, it could have explained why there is no hostname for your corresponding public IPv6 address.

From your screenshot, I'd expect a reverse lookup to return gonsaplus as hostname.

Does that IPv4 indeed match the IP on your mobile?
Your earlier mobile screen only shows DNS and IPv6 info, not IPv4.

1 Like
pi@raspberrypi:~ $ host gonsaplus                                                                                                               Host gonsaplus not found: 3(NXDOMAIN)                                                                                                           pi@raspberrypi:~ $ host 192.168.1.80                                                                                                            Host 80.1.168.192.in-addr.arpa. not found: 3(NXDOMAIN)

And in a screenshot a few posts above you can see the IPv6 address of the phone.

@ Bucking_Horn I found this:

This is where it is associating the IP 192.168.1.80 to raspberrypi, although as we know the real one is 192.168.1.88.
How can I fix this? Can I flush these entries?

So I pressed the Flush Network Table in the settings, it wiped all these entries but put back the IP ending in 80 as raspberrypi...

This confirms that :c767 and .80 are related to the same device.
It shows the same unwanted and yet unexplainable association of raspberrypi with those addresses.

Now that we've verified that .80 is your smartphone's IPv4, what does a dig return for that IPv4 address?

1 Like
pi@raspberrypi:~ $ dig -x 192.168.1.80 @192.168.1.88

; <<>> DiG 9.11.5-P4-5.1+deb10u1-Raspbian <<>> -x 192.168.1.80 @192.168.1.88
;; global options: +cmd
;; Got answer:  
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56562   
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1     

;; OPT PSEUDOSECTION:      
; EDNS: version: 0, flags:; udp: 4096 

;; QUESTION SECTION:       
;80.1.168.192.in-addr.arpa.     IN      PTR

;; ANSWER SECTION:         
80.1.168.192.in-addr.arpa. 2    IN      PTR     gonsaplus.amor.  

;; Query time: 1 msec      
;; SERVER: 192.168.1.88#53(192.168.1.88)         
;; WHEN: qua jul 01 11:06:38 WEST 2020
;; MSG SIZE  rcvd: 82

Yes now the return of dig is right, it associates with the right hostname gonsaplus.
How and why is it showing up in the network table and clients as raspberrypi???

We haven't figured that out yet.

We have only just confirmed that it's not your Pi-hole's DNS providing that information, as that correctly returned gonsaplus as a name for your IPv4 .80.

What's the output of the following command, run from your Pi-hole machine?

sudo grep -nR "raspberrypi" /etc/pihole/*.list /etc/pihole/dhcp.leases /etc/hosts /etc/dnsmasq.d/
1 Like
pi@raspberrypi:~ $ sudo grep -nR "raspberrypi" /etc/pihole/*.list /etc/pihole/dhcp.leases /etc/hosts /etc/dnsmasq.d/
/etc/pihole/local.list:1:192.168.1.88 raspberrypi
/etc/pihole/local.list:2:2001:8a0:574c:e301:4d99:d1e0:7c76:4db3 raspberrypi
/etc/hosts:2:127.0.0.1  raspberrypi

That shows the definitions for raspberrypi to be correct - that name is configured for your Pi-hole machine only.
I am out of ideas as to what could be causing this.

As your dig commands have shown, clients in your network are able to receive the correct names.

This would limit this behaviour to Pi-hole's UI only, possibly a glitch.

@yubiuser, I know you to have tested upcoming changes in Network overview a lot - are you aware of erroneous associations of IP addresses and hostnames?

1 Like

Not in a sense I saw it here. The only things that comes to my mind is this thread:

I also thought that the wrong hostname must come from somewhere - maybe there are some hostname related settings left on the router (even when DHCP is disabled)? What router do you use?

1 Like

Router is Technicolor TG789vac v2.
Some more screens from the router:

Even if DHCP is disabled on the router and only active via Pihole - try to delete the DHCP address pool and reboot the device.

One thing I noticed today:

pi@raspberrypi:~ $ nslookup 192.168.1.100                                                                               100.1.168.192.in-addr.arpa      name = blackbeast8.lan.                                                                                                                                                                                         pi@raspberrypi:~ $                                     

Shouldn't the name be blackbeast8.amor as on the Network tab?

.lan is the default domain of Pi-hole. I created the .amor domain.
What is going on?