iPhone does not use pi-hole despite having dns set manually in settings

I’ll contact Apple Support and see what I can find out.

Apple Support was no help and instead suggested I make a phone call to Engineering to make a report of the situation. I decided to try one more thing (which in reality shouldn’t make any difference at all), but I’m going to set up a small gigabit switch and run my pi-hole one hop away from the gateway to see if there’s improvement.

That won’t make any difference.
Pi-hole will work as long as it is operating within the same local subnet. If anything, physically segregating Pi-hole from its potential clients might increase the likelihood of configuration errors outside Pi-hole.

From your later set of screenshots, I have noticed that in the short period that your iPhone showed up in Pi-hole, it was only issueing IPv4 queries.
That bring’s up a remaining possiblity:

Have you checked IPv6?

IPv6 is disabled on the router and the pi-hole.

Apple support was no help. They said their help ended at connection to the internet. Despite their device not running DNS queries through the IP of my choice, they said I could only report a bug to engineering and that I had to do it over the phone. I’m not about to spend two hours of my life on hold with Apple Engineering to report a bug that will get dropped in the bin.

Nonetheless, I’m going to try putting the Pi-Hole behind another switch and see what happens. If that doesn’t work, I’m going to throw it in the DMZ and see what happens. If that doesn’t work, I’m testing an android phone on my network. If that works, my iPhone will be thrown into the nearest 8 lane highway.

What will happen is that you will create an open resolver and your DNS server will soon be found and put to no good use. DON’T DO THIS.

I’m not confident this is a bug. I don’t have that model phone to compare with, but perhaps another user has such a phone and there are settings that can be changed. Is there any other software running on the phone (VPN, 1.1.1.1, etc) that can change DNS settings?

As far as I know, no. I can’t be bothered to check each individual application, so I’ll probably create a backup of the phone tonight and then do a factory restore to test. If still not working I don’t know what I’ll do. This is mildly infuriating.

Edited by moderator to remove animated gif.

Maybe try the latest stable version and not the beta ?

This is definitely iOS level related as this is not common.

I cannot replicate it since I don’t know what’s happening and I am not seeing the same behavior on any of my 6 apple devices that are constantly ON.

You can try one more thing … but this would be like a last resort and only for testing purposes (in this scenario, as it should work bare bones with iOS straight up).

Set up a VPN … see if it bypasses the tunnel too …

I have gone back to the latest stable iOS build as of around a week and a half ago.

Have you verified that there are no VPN services on the iPhone?

There is no VPN on my phone at all.

Sorry I’m late to the party, I’ve been following this thread for a couple of days to see if someone could identify a fix…
I updated my phone to 13.2 a few days ago, lost my access to Pi-Hole via manual DNS and have been attempting to find a solution. I only had Pi-Hole as the DNS provider, but adding Dyn worked, which confirmed that my phone wasn’t talking to Pi-Hole.

My Pi-Hole instance was running on a stand-alone Pi over Wi-Fi on a flat local network.
All other devices on my network (iOS included) had no problems:
As my phone was unable to access the dashboard too, I reasoned that maybe PiHole or the flat Linux build (installed) had blocked my phone due to some iOS strangeness which Apple (as always) would never admit to, after a few days searching I threw-in the towel.

Now; the work-around was to plug in a CAT5, bounce the box, find the new IP address and add it to my phone’s manual DNS list, remove all the other DNS providers and flush the DNS. I’d consider this fixed, but I’m not a software engineer and realise that it is only a work-around.
I’d be interested to discover if Pi-Hole can block a device or could it be down to something else?
I’m merely a regular Joe and not a Linux administrator, but any clues would be much appreciated.

Android have an option to activate “private DNS”.

https://blog.cloudflare.com/enable-private-dns-with-1-1-1-1-on-android-9-pie/

Updating now … on 13.1.2 i have no issues. Pi-hole IP is the DNS used. Obtained via DHCP.

I have had no issues with 13.2 on multiple IOS devices, all manually mapped to two different Pi-Holes.

I have run a different test here:

I put the pi-hole behind another switch. Router(Default Gateway)->Switch->pi-hole and no change.

I opened firefox on my PC and enabled DNS over HTTPS and now the browser requests don’t go through pi-hole. Is it possible the iPhone isn’t running its DNS requests over port 53? And as a result, the pi-hole doesn’t get that traffic?

This may be the case if you have additional software installed. As shipped, an IOS device uses the DNS specified by the DHCP server.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.