IP does not match the IP found in /etc/pihole/setupVars.conf


#1

Please follow the below template, it will help us to help you!

Expected Behavior:

It is supposed to be the same.

Actual Behaviour:

But the IP of 192.168.0.104/24 does not match the IP in /etc/pihole/setupVars.conf

Debug Token:

bl9ufuilcl

I really don’t know whats wrong and I am very new to all this, so sorry if the questions are basic/


#2

Run pihole -r to reconfigure with the correct IP address.


#3

EDIT: I reinstalled the whole OS and the pi-hole. But now my pi-hole IPv4 address is 192.168.0.104/24. I don’t know what the /24 stands for but it seems to be running on my VBox. However my Vbox IPv4 is also 192.168.0.104. I don’t know if this calls for any concern?


#4

You will run into a conflict if two devices are trying to use the same IP. You can use DHCP reservations to prevent this and still always give the device the same IP address every time.


#5

I tried setting the IPv4 of the pi-hole to be 192.168.0.130 to prevent conflict. But the problem is I never see the pi-hole ip in my router Connections settings. I just see the VBox connected to the router. So I don’t know what’s going on? Setting it to 192.168.0.130 also leads to the error of ip not matching in /etc/pihole/setupVars.conf


#6

If you’re statically setting the IP address on the Pi-hole, it won’t show up in your router’s interface. For that, you’d need to use the DHCP reservations.

To fix that error, you can run set the correct IP in /etc/pihole/setupVars.conf and then runpihole -r > Repair.


#7

Yep that fixed it. Thanks for everyone’s help! Sflr :sweat_smile:


#8

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.