Installation on CentOS 8 stopping

We have a problem installing Pi-hole on a CentOS 8. The installer script stops on this position:

[βœ“] Check for existing repository in /etc/.pihole
[βœ“] Update repo in /etc/.pihole

[βœ“] Check for existing repository in /var/www/html/admin
[βœ“] Update repo in /var/www/html/admin

[i] Main Dependency checks…
[βœ“] Checking for php-pdo

Unfortunately we can find no installer log to debug the process.

Does anyone have a clue how the get some information about whats going wrong here?

Thank you very much!

CentOS 8 is not a supported OS. There are some dependencies that are not available.

Hi jfb,

we know that is is actually not supported, is there any workaround or something?

Here are some notes from a developer on this topic - this has not been tested, so your results may not be satisfactory.

Looks like lighttpd & lighttpd-fastcgi are not available in the CentOS 8 EPEL repo.

I would suspect if a user was to install lighttpd and lighttpd-fastcgi manually. If not installed via yum/dnf, they would also want to remove them from the dependency list before re-running the installer.

As noted above, the lighttpd packages that we require from the EPEL repositories do not appear to be available. CentOS 8 will remain unsupported until the packages are available and/or we remove the lighttpd from the project.

That said, I have provided a workaround below that will compile lighttpd from source and edit the install script to remove lighttpd from the dependencies. I hope this helps :wink:


UNSUPPORTED WORKAROUND

WARNING: The following paste contains the commands to set selinux to permissive. The project does not support selinux and will not function properly in enforcing. Please understand the consequences and if you require selinux enforcing, you will need to create a custom selinux policy to allow the project to function properly.

Instructions:
As root, copy the entire text below and paste to terminal. Do not save as script, ensure you copy all lines including # <- COPY START all the way to the bottom including # <- COPY END.


# <- COPY START
if [ ! -f "/usr/local/sbin/lighttpd" ]; then
dnf install -y autoconf make automake libtool pcre-devel zlib-devel bzip2-devel git

git clone https://git.lighttpd.net/lighttpd/lighttpd1.4.git
cd lighttpd1.4
./autogen.sh
./configure --disable-dependency-tracking
make
make install

cat << EOF > /etc/systemd/system/lighttpd.service
[Unit]
Description=Lightning Fast Webserver With Light System Requirements
After=syslog.target network-online.target

[Service]
PIDFile=/var/run/lighttpd.pid
EnvironmentFile=-/etc/sysconfig/lighttpd
ExecStart=/usr/local/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf

[Install]
WantedBy=multi-user.target
EOF

systemctl daemon-reload
systemctl enable lighttpd

mkdir -p /srv/www
mkdir -p /etc/lighttpd/conf.d
mkdir /etc/lighttpd/vhosts.d
cp doc/config/*.conf /etc/lighttpd/
cp doc/config/conf.d/*.conf /etc/lighttpd/conf.d

groupadd lighttpd
useradd -r -M -g lighttpd lighttpd

mkdir /var/log/lighttpd
chown lighttpd: /var/log/lighttpd
fi

setenforce 0
sed -i "s/^SELINUX=enforcing/SELINUX=permissive/" /etc/selinux/config

dnf install -y epel-release php-json git

git clone --depth 1 https://github.com/pi-hole/pi-hole.git Pi-hole
cd "Pi-hole/automated install/"
sed -i "s/lighttpd\slighttpd-fastcgi//" basic-install.sh
chmod +x basic-install.sh
./basic-install.sh
# <- COPY END


1 Like

Hi bcambl,

thank you very much, that seems to be working!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.