I'm moving from Rpi to docker and need a bit of help

#1

I’ve been running Pi-Hole on a RPi for some time and have just bought a Synology NAS and have installed Pi-Hole in Docker.

It installed fine but continually restarts itself and I haven’t managed to access the admin page so far as the run time is so short.

Here’s how it is configured:

The only errors and warnings are as below:

I have little experience with docker and all things network are a bit of a mystery.

Any help will be much appreciated.

0 Likes

assigned diginc #2
0 Likes

#3

Looks like you just ran it without any customizations.

this blog should guide you through what settings you’ll need to get it running.

0 Likes

#5

I had to put this on the back burner to do other stuff, but now I’ve made progress.

I had my Pi-Hole running on 10.0.1.31 on my Rpi with ‘whole house’ ad blocking working great on all devices with my router DNS set to 10.0.1.31.

I now have it installed and running in docker on a Mac Mini at 10.0.1.47.

I access the admin page from any device at 10.0.1.47.

Ads are being blocked fine on the Mac Mini, that has docker and Pi-hole running, but not on any other device.

I have my DNS in my router set to 10.0.1.47 and have also set it to that on my Macbook and iMac. Still no blocking.

Below is a screenshot of the docker containers and settings:

I’m sure this is just a simple setting change requirement but my network knowledge is still a persistent challenge.

Any help to point me in the right direction will be much appreciated.

0 Likes

closed #6

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes