I keep losing the linux box on the network and down goes DNS

So, I loaded Pi-Hole on the latest stable Ubuntu on an “Azulle Byte Plus” mini PC. I wiped the drive (card) inside, so it’s just Ubuntu. When everything is working, Pi-Hole runs great. But, randomly I have to reboot the Linux box because I lose DNS.

It happens about 1-2 times a day where DNS would simply stop working. I can’t access the internal IP of the Linux box, yet it is still running.

If I turn on the screen attached to the box, everything is running as well as Pi-Hole. However, the box isn’t communicating with the network, therefore network can’t communicate with the box for DNS instruction. I reboot the box, and everything is back online.

Could this be the onboard ethernet? Ubuntu recognized it without any issues and no special actions had to be taken to install anything. Looking at the history of the Byte Plus and the fact that it uses Intel Cherry Trail processor, it kind of had a dark past with Linux. However, all seems to be good know…or maybe not? Before I scrap everything and start over using a different solution, I wanted to toss the scenario out there to make sure I’m not losing my mind :slight_smile:

The odd thing, Alexa speakers still worked on the network (the only thing that works when this happens). Even for playing music from Pandora. I bet they communicate via IP for everything and thus don’t need DNS to be functioning…

You may have better response for a solution in a different forum (Ubuntu, Byte plus).

I figured I would start here just in case the issue might be being caused by Pi-Hole somehow in someone else’s experiences. I doubt it though as the system is def more powerful than a small ras-pi, but still worth asking nonetheless. :slight_smile:

Generate a debug log, upload it and post the token, and we will check your Pi-Hole for problems.

Ok, no problem.

[✓] Your debug token is: https://tricorder.pi-hole.net/jctfydsvgw

Your debug log shows no problems with Pi-Hole.

   [2019-08-14 00:12:40.635 1395] Imported 50872 queries from the long-term database
   [2019-08-14 00:12:40.636 1395]  -> Total DNS queries: 50872
   [2019-08-14 00:12:40.636 1395]  -> Cached DNS queries: 16129
   [2019-08-14 00:12:40.636 1395]  -> Forwarded DNS queries: 27117
   [2019-08-14 00:12:40.636 1395]  -> Exactly blocked DNS queries: 7626
   [2019-08-14 00:12:40.636 1395]  -> Unknown DNS queries: 0
   [2019-08-14 00:12:40.636 1395]  -> Unique domains: 3056
   [2019-08-14 00:12:40.636 1395]  -> Unique clients: 2
   [2019-08-14 00:12:40.636 1395]  -> Known forward destinations: 4

Thank you, I appreciate that. I would say it confirms that it must be the box. I just tried to stress test the network. I maxed the bandwidth/speed out (ISP-wise at 350Mbps) and downloaded via another PC on the network, a 20GB dummy file from Newsgroups that was split into multiple files/posts and thus 20 connections running at the same time to download it all, and the box vanished from the network in the matter of a few minutes. So it must be a crud network chipset. I have my adapter coming in tomorrow (USB-A to USB-C) and I will try a USB-C hub that has ethernet to see if that helps. If not, it’s off to build a new box I guess :frowning:
Thanks again