Https://tricorder.pi-hole.net/c9zw4ovvkm

Please follow the below template, it will help us to help you!

If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using nginx instead of lighttpd, or there is some other aspect of your install that is customised) - please use the Community Help category.

Expected Behaviour:

ipv6 is not working

Actual Behaviour:

ipv6 working

Debug Token:

https://tricorder.pi-hole.net/c9zw4ovvkm

https://tricorder.pi-hole.net/c9zw4ovvkm

Your debug log shows IPv6 to be fully operational on link for your Pi-hole:

*** [ DIAGNOSING ]: Name resolution (IPv6) using a random blocked domain and a known ad-serving domain
[✓] aximpro.matomo.cloud is  via localhost (::1)
[✓] aximpro.matomo.cloud is  via Pi-hole (fe80::ba27:ebff:feee:517f)
[✓] doubleclick.com is 2404:6800:4015:801::200e via a remote, public DNS server (2001:4860:4860::8888)

However, it contains a few other irregularities, unrelated to IPv6.

If you were to share a more detailed problem description, we might be able to point you in the right direction.

Hi Bucking_Horn,

Thank you.

At times is can be quick, other times painfully slow to if at all it returns a result. Sometimes no result at all.

Any suggestions on the irregularities?

Thanks
Stuart

What makes you suspect that IPv6 wouldn't work?

Is it nslookup or dig failing or being slow when requesting resolution via IPv6?

Hi,

It is both nslookup / dig failing.

Stuart

Please provide some sample outputs, including the exact commands you were using, preferably as text.

pi@raspberrypi:~ $ dig pimylifeup.com @127.0.0.1

; <<>> DiG 9.10.3-P4-Raspbian <<>> pimylifeup.com @127.0.0.1
;; global options: +cmd
;; connection timed out; no servers could be reached
pi@raspberrypi:~ $ dig pimylifeup.com @192.168.0.55

; <<>> DiG 9.10.3-P4-Raspbian <<>> pimylifeup.com @192.168.0.55
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12720
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pimylifeup.com. IN A

;; ANSWER SECTION:
pimylifeup.com. 289 IN A 172.67.74.74
pimylifeup.com. 289 IN A 104.26.7.238
pimylifeup.com. 289 IN A 104.26.6.238

;; Query time: 33 msec
;; SERVER: 192.168.0.55#53(192.168.0.55)
;; WHEN: Sun May 09 09:50:42 AEST 2021
;; MSG SIZE rcvd: 133
pi@raspberrypi:~ $ dig pimylifeup.com @192.168.0.55

; <<>> DiG 9.10.3-P4-Raspbian <<>> pimylifeup.com @192.168.0.55
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17973
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;pimylifeup.com. IN A

;; ANSWER SECTION:
pimylifeup.com. 289 IN A 104.26.6.238
pimylifeup.com. 289 IN A 104.26.7.238
pimylifeup.com. 289 IN A 172.67.74.74

;; Query time: 6 msec
;; SERVER: 192.168.0.55#53(192.168.0.55)
;; WHEN: Sun May 09 09:50:53 AEST 2021
;; MSG SIZE rcvd: 91

Hmm, none of those results are for IPv6.
So I am still struggling to understand why you state that IPv6 isn't working for you.

Assuming that you ran those commands from an RPi hosting your Pi-hole, note that Pi-hole installation won't touch your localhost DNS settings.
It will just listen for incoming DNS and forward any non-blocked DNS queries to one of its configured upstreams.

We generally recommend to consider providing a public DNS server for the Pi-hole host machine, but you are free to configure DNS resolution for your Pi-hole host machine in any way you see fit.
Those settings do not interfere with your Pi-hole's operation: It will reliably accept, process and forward DNS queries from your clients.
Particularly, this means your first dig timing out won't affect your clients.

The other two results using Pi-hole look ok.

Did you perhaps change some settings in the meantime?
If so, please provide a new debug token.
Or do so anyway, as your current one is about to expire.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.