How to stop default DNS on UI, after DNS over TLS manual setup


#1

Hello

How can I stop the Pihole UI version 3.3.1 from insisting on a minimum DNS server?

I setup PiHole to use DNS-over-TLS by hand, using Stubby as a local DNS client. I changed the dnsmasq settings to use Stubby. Unfortunately, I can’t switch off the DNS settings in the UI. And it does not allow me to set an alternative port. So now Pihole is making parallel DNS requests to both the settings in my stubby file AND to the stub setting left in the UI (in this case Quad-9), that I can’t switch off. I confirmed this with TCPdump. Here are the stubby settings for DNSmasq

 egrep -v "^#.*|^$" /etc/dnsmasq.d/02-stubby.conf 
server=127.0.2.2#2053
server=0::2#2053

How can I disable the UI settings in Web-UI version 3.3 Pihole version 3.3.1? Or do I just need to specify port 53 in the configs?

Thanks for your help!

Regards

L


#2

To be able to use a custom port through either the webUI or otherwise you need to be on Pi-hole 4.0


#3

OK thanks for the very quick reply! I will upgrade and try again.


#4

Hi technicalpyro. That worked, thanks! I upgraded to v4 and could then set Upstream DNS Servers, Custom 1, “127.0.2.2#2053” (the port that the resolver is listening on, and tested it with tcpdump. The traffic is now going to TCP destination port 853 and is encrypted with TLS.


#5

Really happy you got it going have a great day!