How to set pihole as DNS on Arris TG1682G router (Comcast)?

@jfb

Thanks again. I take it I still need to find a way to make the IP of the pi-hole static for this, right?

Also “renew DHCP lease”? I guess I can set the timer to 1 second, save, and then un-do it?

My guess is if you scroll up on the screenshot that you provided in your post, you may see the enable/disable DHCP checkbox. @jfb covered the appropriate DHCP range settings to use.

Pi-Hole should have set a static IP when it installed. Run this command from the Pi terminal and it will show all the non-commented lines in the specified file. Four of the lines (towards the bottom) should specify the interface, IP, gateway and nameserver.

sudo grep -v '#\|^$' /etc/dhcpcd.conf

A typical configuration for a Pi running on ethernet will look something like this:

interface eth0
    static ip_address=192.168.0.155/24
    static routers=192.168.0.1
    static domain_name_servers=127.0.0.1
1 Like

@jfb

Yes, my results are similar to what you showed with that command.

How do I get that nice GUI interface that I saw some of the tutorials show with the checkbox for DHCP for the pihole?

@Tesserax Unfortunately, there is no such checkbox for the router.

This is on the web admin GUI > settings > DHCP page

@jfb

I mean, I don’t know how to open the GUI in the first place. It’s not in the applications on the raspberry pi, at least anywhere I can find. I didn’t see an argument I could pass to pihole to make it open either.

The GUI is an option that you select to configure at Pi-Hole install. If you run pihole -r and select “reconfigure”, it will ask if you want the web admin installed. Say yes.

You may already have it installed and don’t know how to access it. From a browser, type

http://pi.hole/admin

1 Like

See edit above. You have to open the admin page in a browser.

Thanks.

@jfb

Apparently the beginning and ending address of the DHCP cannot be the same. :frowning:

Make them one apart.

@jfb

What happens with this “emtpy slot”? If I say, set the router to .56 and .57, the pi is on .56 and sends to .58 to .250 or whatever.

.57 would be this “empty slot”. I don’t know networking at all, does this mean it could hook up one of my devices to .57, and thus completely miss the DHCP work that the pi is doing?

Yes, this would be the case.

You may be able to assign a reserved DHCP lease to that address using a Mac address that doesn’t exist on your network.

@jfb

How do I check if any of this is working?

When I go into my network overview, it shows 3 devices, but it isn’t seeing my laptop or phone connected via wifi.

You will need to reboot the router, then renew the DHCP lease on all the connected clients.

How do I renew the DHCP lease?

Depends on the client. Windows from the command prompt ipconfig /renew

MacOS from the Mac terminal sudo killall -HUP mDNSResponder

iPhone put in airplane mode for 10 seconds, then back to WiFi.

Android you’d have to Google it, I don’t have those platforms.

1 Like

@jfb

It looks like everything is working. All 5 of my devices are showing up in the gui as protected. For awhile there I completely lost internet, and what I did have after was behavior very odd. However, seems to have fixed itself.

Thanks for all the help!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.