How to re-enable web interface?

My pi-hole installation runs on RPi 3 since mid-2016. For some unfortunate reason I chose to upgrade the OS to Bullseye and disaster struck.

Navigating to http://localhost/admin displays raw PHP page. Also, even after issuing the command to restart DNS, the system reports that DNS is not running. There is no standalone dnsmasq in the system.

I stepped through the two configuration options but the end result did not change. I cannot display the web admin dashboard page.

Here are some sample output from my operations:

chowkidar@raspbari25:~/projects $ sudo service dnsmasq stop
Failed to stop dnsmasq.service: Unit dnsmasq.service not loaded.
chowkidar@raspbari25:~/projects $ sudo systemctl disable dnsmasq
Failed to disable unit: Unit file dnsmasq.service does not exist.
chowkidar@raspbari25:~/projects $ sudo service pihole-FTL start
chowkidar@raspbari25:~/projects $ sudo service pihole-FTL status
● pihole-FTL.service - Pi-hole FTL
     Loaded: loaded (/etc/systemd/system/pihole-FTL.service; enabled; vendor pr>
     Active: activating (auto-restart) (Result: exit-code) since Tue 2023-01-31>
    Process: 11798 ExecStartPre=/opt/pihole/ (code=exited>
    Process: 11811 ExecStart=/usr/bin/pihole-FTL -f (code=exited, status=2)
    Process: 11812 ExecStopPost=/opt/pihole/ (code=exited>
   Main PID: 11811 (code=exited, status=2)
        CPU: 2.361s
chowkidar@raspbari25:~/projects $ sudo netstat -nltup | grep 'Proto\|:53 \|:5053 \|:5353 \|:5335 \|:8953 \|:67 \|:80 \|:471'
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0  *               LISTEN      317/connmand        
tcp6       0      0 ::1:53                  :::*                    LISTEN      317/connmand        
tcp6       0      0 :::80                   :::*                    LISTEN      665/apache2         
udp        0      0  *                           317/connmand        
udp        0      0*                           10903/chromium-brow 
udp        0      0  *                           302/avahi-daemon: r 
udp6       0      0 ::1:53                  :::*                                317/connmand        
udp6       0      0 :::5353                 :::*                                302/avahi-daemon: r
 chowkidar@raspbari25:~ $ pihole status
  [✗] DNS service is NOT running
  [✗] DNS service is NOT running
chowkidar@raspbari25:~ $
chowkidar@raspbari25:~ $ pihole -v
  Pi-hole version is v5.15.3 (Latest: v5.15.3)
  AdminLTE version is v5.18.3 (Latest: v5.18.3)
  FTL version is v5.20.1 (Latest: v5.20.1)
chowkidar@raspbari25:~ $

Thanks for your help.


pihole-FTL needs port 53 to work, but connmand is using this port.
Also, you have apache2 using port 80. This port is used by lighttpd to show the web interface.

You need to disable connmand and apache.

Thanks for the prompt response. I have zero knowledge why Apache and connmand (don't even know what it does) would be installed through the Bullseye full-upgrade. I will do as advised. Luckily, I have teleporter files too!


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.