Having problems with pihole (unbound)

The issue I am facing:
I am unable to update my lists as I seem to be having DNS issues. I tried to update and got an error. I generated a debug list but was unable to upload it due to connectivity issues. I tried to reinstall my pi and got this error: https://pastebin.com/KvwLRrR7

I also tried doing this: https://pastebin.com/ZVNCzh9R

sudo nano /etc/resolv.conf gives me the nameserver 127.0.0.1 since I'm using unbound

Details about my system:
Rasp Pi 3

What I have changed since installing Pi-hole:
Pihole was working perfectly fine until a few weeks ago. I updated my router firmware, not sure if that has changed anything, and I updated Pihole to the latest version. I do know that loading my router pages is now agonizingly slow, i think it's just limited to my local network.

Also I wasn't able to post this multiple times because it said new users can't mention other users and had to put all my info in the pastebin links

Edit: I've also noticed I've gone from 20-30% blocked to now 6% blocked sites. I'm assuming it's because my lists are no longer working.

What is your actual problem?

  • Unable to update blocked lists
  • unable to reinstall pihole
  • unable to connect at all to anything pihole related
  • dns issues with my router (my router says it's not connected to the internet but it is)
  • decrease in blocked sites due to block lists not being updated and being unable to add new ones
  • unable to upload debug log to pihole
pi@raspberrypi:~ $ dig +short -t txt versions.pi-hole.net @ns1.pi-hole.net
dig: couldn't get address for 'ns1.pi-hole.net': failure

pi@raspberrypi:~ $ nslookup ns1.pi-hole.net
;; connection timed out; no servers could be reached

pi@raspberrypi:~ $ nslookup ns1.pi-hole.net 1.1.1.1
;; connection timed out; no servers could be reached

You got network connectivity issues. Most likely because of

Do you have any firewall in place preventing traffic on port 53 outbound

I shouldn't because I haven't touched the firewall since I got the router, but I will check. Is there a way to check without checking my router control page?

Edit: checked my router page, nothing here

The first line clearly states "Firewall enabled".
Do you have any outbound rules applied. What router model is this?

Hm, I'm not sure where to check outbound rules. This is a Asus GT-AC5300

Edit: do you mean I should forward port 53?

No!

It is likely your router's firmware:

https://rog.asus.com/forum/showthread.php?124137-GT-AC5300-Firmware-3-0-0-4_386_42643-DNS-Issue-(PiHole)

1 Like

Thank you!! This fixed it!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.