Group Management help needed

I’m still having some issues with group management.

I’ve added clients (IP and MAC) to a disabled group, and removed from the default group. Still seems to get blocked, until I disable all for example 60 min from the top menu.

I must still be missing something here, so would appreciate some ideas to try to fix.

Thanks, Carl

Please upload a debug log and post just the token generated by

pihole -d

allowing to upload when prompted, or do it through the Web interface:

Tools > Generate Debug Log

jfb, here is the token. https://tricorder.pi-hole.net/kv2fxz4bj0/

I think I may have found the issue, needing to put a /24 after the IP address for an unblocked client. Not sure why that was needed vs. just the IP address itself. I also had MAC address listed for unblocked and that didn't seem to work.

Will try some more and make sure that was the case,

Carl

You should not need the subnet mask after the IP. Note that you have the same IP in two different groups. Did you intend for 101 to be in group 1?

*** [ DIAGNOSING ]: Clients
   id    group_ids     ip                                                                                                    date_added           date_modified        comment                                           
   ----  ------------  ----------------------------------------------------------------------------------------------------  -------------------  -------------------  --------------------------------------------------
...
   7     1             192.168.168.101                                                                                       2020-12-26 19:51:21  2020-12-26 19:51:56  CSM iPhone                                        
   8     0             192.168.168.101/24                                                                                    2021-01-01 07:46:30  2021-01-01 07:46:30  CSM iPhone

You also have the unblocked group disabled:

*** [ DIAGNOSING ]: Groups
   id    enabled  name                                                date_added           date_modified        description                                       
   ----  -------  --------------------------------------------------  -------------------  -------------------  --------------------------------------------------
   0           1  Default                                             2020-05-19 14:49:25  2020-12-20 17:16:18  The default group                                 
   1        0     Unblocked                                           2020-12-06 07:48:39  2020-12-20 17:14:04  Unblocked clients

Separate observation on your regex entries - https: is never part of a domain name, so these entries don't work as you expect. Enter the domain only, then add to the blacklist or whitelist as a wildcard, and Pi-hole will make the correct regex.

   18      2         1  0             (\.|^)https://link\.popularmechanics\.com$                                                            2020-05-30 11:04:13  2020-05-30 11:04:13                                                    
   19      2         1  0             (\.|^)https://link\.popularmechanics\.com/$                                                           2020-06-02 20:53:47  2020-06-02 20:53:47                                                    
   20      2         1  0             (\.|^)http://click\.em\.dpmag\.com/$                                                                  2020-06-03 13:08:10  2020-06-03 13:08:10                                                    
   21      2         1  0             (\.|^)link\.outsideonline\.com$                                                                       2020-06-09 08:30:36  2020-06-09 08:30:36

jfb,

IP 101 should be in the Unblocked group. When I added new /24, (looks like I can't edit, so added a new one) it looks like it was also in the Default group in error.

I disabled the Unblocked group, as it seemed like the setting based on when I "disable" PiHole temporarily in main menu. Should I "Enable" the Unblocked group?

If you want it to be a working group, yes.

I'll try that. I had disabled as it didn't seem like it was working otherwise. I'll go back to removing the /24 and double check the settings and see if I can narrow it down further.

Guess I'm still not sure how it works. For IP 101 I'd like to not have any blocked, so how do I configure that. I was thinking I would disable the unblocked group.

jfb - Back to original debug, if I list IP 101 in Unblocked, it still didn't get to a website that had some ad forwarding. If I add another IP 101/24, then it worked ok. That was the only change I made. Unblocked is Enabled.

I also tried adding a "*" regex to unblock all domains, but that didn't work. Only when I added the /24 did it then get through to the website.

Carl

jfb, I'm still not sure why the /24 is working, but when I remove this, then it doesn't work. Let me know anything else I can check.

Thanks, Carl