# Getting SERVFAILs after upgrade on Raspian 10

**URL:** https://discourse.pi-hole.net/t/getting-servfails-after-upgrade-on-raspian-10/75279
**Category:** Help
**Created:** [January 21, 2025, 9:01pm UTC](https://discourse.pi-hole.net/t/getting-servfails-after-upgrade-on-raspian-10/75279 "2025-01-21T21:01:47Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![bkd84wktgc0k](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/b/bc79bd/32.png) [@bkd84wktgc0k](https://discourse.pi-hole.net/u/bkd84wktgc0k)
#### Post date: [January 21, 2025, 9:01pm UTC](https://discourse.pi-hole.net/t/getting-servfails-after-upgrade-on-raspian-10/75279/1 "2025-01-21T21:01:47Z")

</div>

#### Please follow the below template, it will help us to help you!

### _If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using `nginx` instead of `lighttpd`, or there is some other aspect of your install that is customised) - please use the [Community Help](https://discourse.pi-hole.net/c/bugs-problems-issues/community-help/36) category._

## Expected Behaviour:

-hardware: Raspberry Pi Model B 2012  
-OS: Raspian 10 (Buster)  
-Pi-Hole: v5.18.4  
-FTL: v5.25.2  
-Web interface: v5.21

Today, I attempted to run `pihole -up` and received the message that Buster was no longer supported, so I ran

```auto
sudo PIHOLE_SKIP_OS_CHECK=true pihole -r

```

I chose the repair option, and the install appeared to be successful.

I would expect Pi-Hole to continue running as before.

## Actual Behaviour:

I am now getting SERVFAILs on random domains.

A workaround I found is when I change my upstream DNS server to for example Quad9, DNS resolution starts working again. Previously, my upstream DNS server was a DNS server provided behind the VPN I pay for along with its public IP as a backup.

When I try to change DNS settings from the web interface, I now get the message

```auto
There was a problem applying your settings.
Debugging information:
PHP error (2): fsockopen(): unable to connect to 127.0.0.1:4711 (Connection refused) in /var/www/html/admin/scripts/pi-hole/php/FTL.php:47

```

and FTL stops for about 10-15 seconds before restarting. Not sure if this is related.

## Debug Token:

[https://tricorder.pi-hole.net/mQppsUgU/](https://tricorder.pi-hole.net/mQppsUgU/)

---

<div class="post-metadata">

### Author: ![system](https://discourse.pi-hole.net/uploads/default/original/3X/7/c/7c8792f649eeb921c5d2b4c41564ffa873d9a2b8.png) [@system](https://discourse.pi-hole.net/u/system)
#### Post date: [February 11, 2025, 9:01pm UTC](https://discourse.pi-hole.net/t/getting-servfails-after-upgrade-on-raspian-10/75279/2 "2025-02-11T21:01:55Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
