Getting ready for Buster

Now the RaspberryPI 4 is announced and is going to use Debian Buster as image OS what are the problems that are going to spoil the usage of Pi-hole on that RaspberryPI version?

The feature request is to adapt Pi-hole so that is compatible with Debian Buster.

Update: the solution by bene987 made it possible to use Lighttpd on Buster with the Pi-hole default config for Lighttpd. After that the default (Master) of Pi-hole should have the adaptation by the Developers.

Update 2: Pihole is now patched for this and the version number has increased increased to 4.31.
https://github.com/pi-hole/pi-hole/commit/1a741f696eec2ee148fc59bc0dc98e862475e6ef

Has anyone actually tried pihole on Raspbian Buster to see if it runs?

I think the developers sure gonna test it :grinning:
But the PI4B is a huge step forward :+1:

No, it’s not working. I think it’s very stupid because Debian 10 “Buster” will be officially released in a few days!

1 Like

The Dev team is ALL volunteers we all do this on our own time. When support is available for buster it will get posted until then comments that “it’s stupid” really aren’t productive or helpful.

1 Like

I’m sorry. The “it’s stupid” unfortunately came across differently than it was thought. I am very grateful to the Dev Team for their work. The release of Raspbian Buster came unexpectedly and earlier than expected.

The project is working on it

4 Likes

We don’t get any early previews or heads up on what is changed/new/broken when something new comes out. We see it when everyone else sees it and we’ll get to looking at what needs to be updated without losing support for the long term releases.

So we will support it when we can.

3 Likes

wish you luck @DanSchaper :+1:

I’m really grateful for this project,
unfortunately I was stupid enough to update my raspberry where pi-hole is running on to buster.
using this method
https://www.raspberrypi.org/documentation/raspbian/updating.md
but then ofc with duster.
upgrading took met 1.5 hours or something,
and my findings afaiks are the following

  • dns is still worken
  • DHCP v4 is still working(I don’t have IPv6)
  • blocklists are still applied
  • the webinterface is not working,

I tried uninstalling lighttpd, and then pihole -r for repair.
but lighttpd won’t start. unfortunately.

I just want to share this info to help others.

OK - I’ve got pi hole working on a new pi4. It took a while, but I’ve changed over to apache, until the devs get lighthttp config syntax fixed.

FTL initially didn’t wanna play, but upgrading to the dev branch seems to be ok.

I just copied over my SQL databases from my existing pi hole to the new one and all is gooooood.

Edit: oh yeah and now just compiling unbound and it should be fully migrated.

Let’s just say my wife and kids haven’t complained yet…

OK - unbound compiled and installed.

Getting some interesting SQLlite DB errors, but it’s working ok.

Which version? (Unbound)

Version 1.9.2

Excellent good news!!! Thank you

I fixed the webinterface by creating one symbolic link

sudo ln -s /usr/share/lighttpd/create-mime.conf.pl /usr/share/lighttpd/create-mime.assign.pl
5 Likes

So, did you also find that lighttpd wouldn’t start, based on a syntax error in lighttpd.conf?

Did your fix mean that it starts now?

after a few attempts and creating the symbolic link I got it working,
thank you.
you need to use /admin now, If you don’t do this you will get a 400 error
instead of the link to the /admin menu

2 Likes