FTL offline und startet nicht nach Update

#1

Hallo,
ich habe heute pi-hole auf version 4.2 aktualisiert. Leider läuft es nun nicht mehr. In der Weboberfläche ist FTL offline.
Versuche ich in der Kommandozeile den FTL Service zu starten erhalte ich folgende Meldung
`root@raspberrypi:/etc/pihole# sudo /etc/init.d/pihole-FTL start
Not running

dnsmasq: bad option at line 44 of /etc/dnsmasq.d/01-pihole.conf`

Die 01-pihole.conf sieht so aus:

addn-hosts=/etc/pihole/gravity.list
addn-hosts=/etc/pihole/black.list
addn-hosts=/etc/pihole/local.list

localise-queries

no-resolv

cache-size=10000

log-queries
log-facility=/var/log/pihole.log

local-ttl=2

log-async

If a DHCP client claims that its name is “wpad”, ignore that.

This fixes a security hole. see CERT Vulnerability VU#598349

dhcp-name-match=set:wpad-ignore
dhcp-ignore-names=tag:wpad-ignore
server=208.67.222.222
server=208.67.220.220
server=2620:0:ccc::2
server=2620:0:ccd::2
domain-needed
bogus-priv
interface=eth0

Ist hier irgendwas falsch konfiguriert? Line 44 müsste der dhcp-name Eintrag sein.
Hat jemand ein Idee was das Problem sein könnte?

0 Likes

#2

Ja, statt

sollte es

lauten.

0 Likes

#3

Ups, das muss mir irgendwie beim auskommentieren abhanden gekommen sein. :wink:
Der Fehler ist aber auch mit

dhcp-name-match=set:wpad-ignore,wpad

der gleiche.

0 Likes

#4

pihole-FTL muss mindestens in der Version 4.2 sein um die neuen Befehle wie dhcp-name-match zu unterstützen. Siehe pihole -v.

Falls Du eine ältere Version nutzt, entferne diese Einträge zunächst, lass dann pihole -r (Repair) laufen und sie sollten automatisch wieder für Dich installiert werden (nebst einem Download vom aktuellsten FTL v4.2.1).

0 Likes

#5

Die Version wird wahrscheinlich das Problem sein.

Pi-hole version is v4.2.1 (Latest: v4.2.1)
AdminLTE version is v4.2 (Latest: v4.2)
FTL version is vDev-3e40158 (Latest: v4.2.1)

Wie installiere ich die neueste Version? pihole -r hat nicht geholfen. :thinking:

0 Likes

#6

Oh, dann hast Du bereits vorher eine developer Version von FTL genutzt.

Versuch

pihole checkout master
0 Likes

#7

Ok, die FTL Version ist jetzt v4.2.1.
Allerdings läuft der FTL Service nicht.

Feb 07 20:14:37 raspberrypi systemd[1]: Starting LSB: pihole-FTL daemon…
Feb 07 20:14:37 raspberrypi pihole-FTL[27993]: Not running
Feb 07 20:14:40 raspberrypi su[28019]: Successful su for pihole by root
Feb 07 20:14:40 raspberrypi su[28019]: + ??? root:pihole
Feb 07 20:14:40 raspberrypi su[28019]: pam_unix(su:session): session opened for user pihole by (uid=0)
Feb 07 20:14:40 raspberrypi pihole-FTL[27993]: dnsmasq: failed to create listening socket for port 53: Address already in use
Feb 07 20:14:40 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.

Was mache ich jetzt?

0 Likes

#8

netstat -tupln | grep :53

Poste dann die response.

0 Likes

#9
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      1813/dnsmasq
tcp6       0      0 :::53                   :::*                    LISTEN      1813/dnsmasq
udp        0      0 0.0.0.0:53              0.0.0.0:*                           1813/dnsmasq
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           338/avahi-daemon: r
udp6       0      0 :::53                   :::*                                1813/dnsmasq
udp6       0      0 :::5353                 :::*                                338/avahi-daemon: r
0 Likes

#10

You have dnsmasq running as a separate process, which is preventing pihole-FTL from starting.

In Pi-Hole V4.0 and later, dnsmasq is embedded in pihole-FTL, and dnsmasq no longer runs as a separate process. The debug log will show dnsmasq as either failed or inactive. Process pihole-FTL should be shown running on port 53.

https://docs.pi-hole.net/ftldns/dns-resolver/

sudo service dnsmasq stop
sudo service dnsmasq disable
sudo service pihole-FTL restart
0 Likes

#11

Ok, pihole läuft nun wieder wie gewohnt.
Thanks for your great support :+1:

0 Likes

#12

Gern gemacht.

0 Likes

split this topic #13

A post was split to a new topic: Dnsmasq.d - permissions denied

0 Likes