FTL Offline. HELP

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

[Replace this text with what you think should be happening]

Actual Behaviour:

[replace this text with what is actually happening]

Debug Token:

[Replace this text with the debug token provided from running pihole -d (or running the debug script through the web interface]



[✓] Your debug token is: 808g1vvj1c



  • Provide the token above to the Pi-hole team for assistance at
  • https://discourse.pi-hole.net
  • Your log will self-destruct on our server after 48 hours.
  • A local copy of the debug log can be found at: /var/log/pihole_debug-sanitized.log
0 Likes

#2

What is the output of these commands from the Pi terminal:

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'

sudo service pihole-FTL status

0 Likes

#3

The result is

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      5378/lighttpd
tcp        0      0 192.168.1.131:53        0.0.0.0:*               LISTEN      569/named
tcp        0      0 10.8.0.1:53             0.0.0.0:*               LISTEN      569/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      569/named
tcp6       0      0 :::80                   :::*                    LISTEN      5378/lighttpd
tcp6       0      0 :::53                   :::*                    LISTEN      569/named
udp        0      0 192.168.1.131:53        0.0.0.0:*                           569/named
udp        0      0 10.8.0.1:53             0.0.0.0:*                           569/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                           569/named
udp6       0      0 :::53                   :::*                                569/named

and:

sudo service pihole-FTL status
* pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
   Active: active (exited) since Sun 2019-02-10 20:12:08 CET; 8h ago
     Docs: man:systemd-sysv-generator(8)
  Process: 6439 ExecStop=/etc/init.d/pihole-FTL stop (code=exited, status=0/SUCCESS)
  Process: 6446 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/pihole-FTL.service

Feb 10 20:12:06 OverLoad systemd[1]: Starting LSB: pihole-FTL daemon...
Feb 10 20:12:06 OverLoad pihole-FTL[6446]: Not running
Feb 10 20:12:06 OverLoad su[6472]: Successful su for pihole by root
Feb 10 20:12:06 OverLoad su[6472]: + ??? root:pihole
Feb 10 20:12:06 OverLoad su[6472]: pam_unix(su:session): session opened for user pihole by (uid=0)
Feb 10 20:12:08 OverLoad pihole-FTL[6446]: dnsmasq: failed to create listening socket for port 53: Address already in use
Feb 10 20:12:08 OverLoad systemd[1]: Started LSB: pihole-FTL daemon.
0 Likes

#4

This is the problem. Process “named” (which is typically BIND9) is running on port 53, which is preventing pihole-FTL from running on that port. These commands will stop that process, disable it and start pihole-FTL:

sudo service BIND9 stop

sudo systemctl disable BIND9

sudo service pihole-FTL start

0 Likes

#5

I did, but always the usual problem

0 Likes

#6

After you did this, what is the output of sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'

It may be a process other than BIND9 on port 53.

0 Likes

#7

The result is:

:~ $ sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2082/lighttpd
tcp        0      0 192.168.1.131:53        0.0.0.0:*               LISTEN      527/named
tcp        0      0 10.8.0.1:53             0.0.0.0:*               LISTEN      527/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      527/named
tcp6       0      0 :::80                   :::*                    LISTEN      2082/lighttpd
tcp6       0      0 :::53                   :::*                    LISTEN      527/named
udp        0      0 192.168.1.131:53        0.0.0.0:*                           527/named
udp        0      0 10.8.0.1:53             0.0.0.0:*                           527/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                           527/named
udp6       0      0 :::53                   :::*                                527/named
0 Likes

#8

Named continues to run on port 53, so it was not BIND9 but another process that continues to occupy that port.

Run this command to determine the process name for the PID shown. Then stop and disable that process.

ps -fp 527

0 Likes

#9

:~ $ ps -fp 527
UID PID PPID C STIME TTY TIME CMD
bind 527 1 0 14:18 ? 00:00:28 /usr/sbin/named -f -u bind

0 Likes

#10

This is BIND running, not BIND9 as I originally thought it might be.

sudo service BIND stop

sudo systemctl disable BIND

sudo service pihole-FTL start

0 Likes

#11

:frowning: no way. this is the result:

:~ $ ps -fp 527
UID        PID  PPID  C STIME TTY          TIME CMD
bind       527     1  0 14:18 ?        00:00:28 /usr/sbin/named -f -u bind
:~ $ sudo service BIND stop
Failed to stop BIND.service: Unit BIND.service not loaded.
:~ $ sudo systemctl disable BIND
Failed to disable unit: No such file or directory
:~ $ sudo service pihole-FTL start
0 Likes

#12

Try it again with bind written in lower case.

0 Likes

#13

same thing … I have to restore the Raspberry from head?

0 Likes

#14

Als es nicht ein service ist dann probiere die named um zu bringen.

sudo kill -9 527

Kontroliere dann ob die named noch immer lauft.

0 Likes

#15

Now after all this, I wanted to do a restore of PiHole, but it tells me that FLT is not installed and that it is not enabled to download the latest version of the software.

pihole -r

[✓] Root user check

    .;;,.
    .ccccc:,.
     :cccclll:.      ..,,
      :ccccclll.   ;ooodc
       'ccll:;ll .oooodc
         .;cll.;;looo:.
             .. ','.
            .',,,,,,'.
          .',,,,,,,,,,.
        .',,,,,,,,,,,,....
      ....''',,,,,,,'.......
    .........  ....  .........
    ..........      ..........
    ..........      ..........
    .........  ....  .........
      ........,,,,,,,'......
        ....',,,,,,,,,,,,.
           .',,,,,,,,,'.
            .',,,,,,'.
              ..'''.

[i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u1
[i] Repair option selected
[✓] Disk space check
[✓] Update local cache of available packages

[✓] Checking apt-get for upgraded packages… up to date!

[i] Installer Dependency checks…
[✓] Checking for apt-utils
[✓] Checking for dialog
[✓] Checking for debconf
[✓] Checking for dhcpcd5
[✓] Checking for git
[✓] Checking for iproute2
[✓] Checking for whiptail

[i] Performing reconfiguration, skipping download of local repos
[✓] Resetting repository within /etc/.pihole…
[✓] Resetting repository within /var/www/html/admin…
[i] Main Dependency checks…
[✓] Checking for cron
[✓] Checking for curl
[✓] Checking for dnsutils
[✓] Checking for iputils-ping
[✓] Checking for lsof
[✓] Checking for netcat
[✓] Checking for psmisc
[✓] Checking for sudo
[✓] Checking for unzip
[✓] Checking for wget
[✓] Checking for idn2
[✓] Checking for sqlite3
[✓] Checking for libcap2-bin
[✓] Checking for dns-root-data
[✓] Checking for resolvconf
[✓] Checking for libcap2
[✓] Checking for lighttpd
[✓] Checking for php7.0-common
[✓] Checking for php7.0-cgi
[✓] Checking for php7.0-sqlite3

[✓] Enabling lighttpd service to start on reboot…

[i] FTL Checks…

[✓] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary…
[✗] Downloading and Installing FTL
Error: Unable to get latest release location from GitHub
[✗] FTL Engine not installed

0 Likes

#16

Pihole -r will not resolve your problem.

As long as you have another process running on port 53, pihole-FTL will not be able to launch and Pi-Hole will not work. Repairing or reinstalling Pi-Hole will not change this.

You will need to figure out what is running “named” on port 53 and stop/disable that.

0 Likes

closed #17

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes