FTL not running after YouTube restricted mode change

Hi Jayke, I'm new to the Pi-hole world and I'm enjoying it, also starting to familiarize myself with Linux...
I ran the script as instructed here and after running it, my DNS service is not running and the FTL service is offline.
A reboot of my RPI didn't help.
I tried a repair of my install but the issue is still there.

I generated a debug log, token is: 22xd7kanw1
Could you take a look please and see if you can help?

Thank you!

Jayke does not have access to your debug log. I took a look at your log and pihole-FTL is not running.

*** [ DIAGNOSING ]: Ports in use
*:22 sshd (IPv4)
*:22 sshd (IPv6)
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd

What are the outputs of

sudo service pihole-FTL status

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'

I am also moving this problem to a new thread.

Hi jfb,

Thank you for looking into it. Much appreciated. Here are the outputs:

pi@raspberrypi:~ $ sudo service pihole-FTL status
‚óŹ pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated; vendor preset: enabled)
   Active: active (exited) since Wed 2019-06-19 14:55:18 BST; 2h 30min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1745 ExecStop=/etc/init.d/pihole-FTL stop (code=exited, status=0/SUCC
  Process: 1751 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SU
   CGroup: /system.slice/pihole-FTL.service

Jun 19 14:55:17 raspberrypi systemd[1]: Starting LSB: pihole-FTL daemon...
Jun 19 14:55:17 raspberrypi pihole-FTL[1751]: Not running
Jun 19 14:55:17 raspberrypi su[1778]: Successful su for pihole by root
Jun 19 14:55:17 raspberrypi su[1778]: + ??? root:pihole
Jun 19 14:55:17 raspberrypi su[1778]: pam_unix(su:session): session opened for u
Jun 19 14:55:18 raspberrypi pihole-FTL[1751]: dnsmasq: duplicate CNAME at line 1
Jun 19 14:55:18 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.

pi@raspberrypi:~ $ sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0    *               LISTEN      1654/lighttpd
tcp6       0      0 :::80                   :::*                    LISTEN      1654/lighttpd

The end of this line appears cut off in your posted output, but given that you were in the dnsmasq configuration files and you now have a dnsmasq error, this is a good place to start.

please run pihole-FTL dnsmasq-test
It should respond with dnsmasq: syntax check OK. but it probably will not.
Correct the error...

1 Like

Awesome. Before running the script I had tried to manually add the cnames.
I deleted the file and ran the script a second time.Now it's working as expected.
Thank you for your help!!!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.