FTL not installed & Unable to get latest release from GitHub


#1

Yesterday I had to reinstall my Pi, so I installed Pihole again. I entered the curl line (without sudo; but that worked before).

Expected Behaviour:

I had hoped that it all worked.

Actual Behaviour:

The web interfaces says connection lost to api. The DNS service is not running and FTL is red (i can’t see the actual text).

pihole -r results in:

  [i] Installing blocking page...
  [✓] Creating directory for blocking page, and copying files
  [✗] Backing up index.lighttpd.html
        No default index.lighttpd.html file found... not backing up

  [✓] Installing sudoer file

  [✓] Installing latest Cron script

  [✓] Installing latest logrotate script

  [i] FTL Checks...
  [✓] Detected ARM-hf architecture (armv7+)
  [i] Checking for existing FTL binary...
  [✗] Downloading and Installing FTL
  Error: Unable to get latest release location from GitHub
  [✗] FTL Engine not installed
  [✓] man pages installed and database updated
  [i] Systemd-resolved is not enabled
  [✓] Starting lighttpd service
  [✓] Enabling lighttpd service to start on reboot
  [i] Restarting services...
  [i] Starting pihole-FTL service...
pi@raspberrypi:~/.homebridge $ 

Debug Token:

[✗] There was an error uploading your debug log.

  • Please try again or contact the Pi-hole team for assistance.
  • A local copy of the debug log can be found at: /var/log/pihole_debug-sanitized.log

I changed the DNS server on my router back to ISP default, rebooted the Pi but there is some trouble connecting I guess… although, I am here posting this


#2

Reset the name server on the Pi to an upstream provider, and then run a repair.

sudo nano /etc/resolv.conf

Change 127.0.0.1 to 1.1.1.1 (or your preferred commercial DNS server), save and exit

pihole -r and select repair