FTL log disk usage

The issue I am facing:
Alert message about disk usage:

2022-01-23
21:29:44 DISK Disk shortage ( `/var/log/pihole-FTL.log` ) ahead: **99% used**
/var/log: 50.7MB used, 50.7MB total

Output from command line by SSH:

root@#$#$#$#$#$:~# sudo du -shc /var/log/*
0       /var/log/alternatives.log
4.0K    /var/log/apt
4.0K    /var/log/armbian-hardware-monitor.log
8.0K    /var/log/auth.log
0       /var/log/bootstrap.log
0       /var/log/btmp
4.0K    /var/log/chrony
4.0K    /var/log/daemon.log
0       /var/log/debug
0       /var/log/dpkg.log
0       /var/log/faillog
0       /var/log/fontconfig.log
48M     /var/log/journal
0       /var/log/kern.log
0       /var/log/lastlog
4.0K    /var/log/lighttpd
16K     /var/log/lost+found
0       /var/log/messages
4.0K    /var/log/mysql
4.0K    /var/log/openvpn
0       /var/log/pihole_debug.log
4.0K    /var/log/pihole-FTL.log
4.0K    /var/log/pihole-FTL.log.save
0       /var/log/pihole.log
0       /var/log/pihole_updateGravity.log
4.0K    /var/log/private
8.0K    /var/log/runit
28K     /var/log/syslog
4.0K    /var/log/sysstat
4.0K    /var/log/unattended-upgrades
0       /var/log/user.log
4.0K    /var/log/wtmp
48M     total

Details about my system:
Armbian on orangepi zero
What I have changed since installing Pi-hole:
Update to the last pihole and FTL version

1 Like

It appears that the file usage is primarily from the journal, and the Pi-hole logs are quite small.

Please generate a debug log, upload it when prompted and post the token URL here.

Are you running log2ram or other similar software?

Hallo and thanks!
No, i never installed log2ram:

root@XXXXXXXXX:~# sudo apt-get remove log2ram
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package log2ram

And, here the Token

https://tricorder.pi-hole.net/KczxywGL/

What is this zram partition?

*** [ DIAGNOSING ]: Disk usage
   Filesystem      Size  Used Avail Use% Mounted on
   udev            189M     0  189M   0% /dev
   tmpfs            50M  5.6M   44M  12% /run
   /dev/mmcblk0p1   58G  1.4G   56G   3% /
   tmpfs           246M  1.2M  245M   1% /dev/shm
   tmpfs           5.0M     0  5.0M   0% /run/lock
   tmpfs           246M  4.0K  246M   1% /tmp
   /dev/zram1       49M  5.3M   40M  12% /var/log
   tmpfs            50M     0   50M   0% /run/user/998
   tmpfs            50M     0   50M   0% /run/user/0

Good question... sincerly i dont know what, this zram1 is!

It appears to be causing the problem here.

Armbian ships with /var/log being a zram mount by default, but of course with persistent journal log this causes issues. So either disable persistent journal logs:

systemctl stop systemd-journald
rm -R /var/log/journal
systemctl start systemd-journald

or disable the Armbian's zram log. Currently not sure how this is done. There is a service called armbian-zram-log or similar, probably disabling it and rebooting does the trick. Find it via:

systemctl

Or Armbian's config tool allows to do it:

armbian-config

zram is btw a compressed RAM block device, similar to tmpfs but with compression.

1 Like

Thanks both for the reply!
With your tips i find out how to stop the log from zram, here:
nano /etc/default/armbian-zram-config

Disabling the log with
ENABLED=false

Seems it fixed the problem!
I will check in a few day if it is solved, thanks.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.