FTL is offline, but pihole works

It tells me to use Netcat and i really don't know what do to

Yeah, that error is a bit vague. There are different versions of netcat out there (netcat, nc, ncat, nmap-ncat, etc.). Interesting you were able to upload the original debug token though.

Will you please make a new debug token for me with pihole -d and then also send me your full log using one of these methods (one should work for you).

Sorry for the late reply! I wasn't home so i couldn't ssh into my pi.

Debug token with pihole -d: ynxs8b17tz

Debug token of the webinterface: od5xaetrbr

Can you try this to try to get your Core up to v3.3?

If it's still offline, try this (it will delete any customizations you may have made to the Web interface).

sudo rm -rf /var/www/html/admin
sudo git clone https://github.com/pi-hole/AdminLTE.git /var/www/html/admin

Both didn't work sadly.

pihole -r

Also didn't work. There was an error that catched my eye.

[X] Downloading and Installing FTL...
Error: Unable to get latest release location from GitHub
[X] FTL Engine not installed

As long as your install is not heavily customized, can you

pihole uninstall
curl -sSL https://install.pi-hole.net | bash

and then revert to 3.2.1 if that's the version you want to be on:

Did that, uninstalled pihole, used that line and it couldn't finish installation.

Error: Could not update local repository. Contact support.

Do you have any customizations in the Web interface? If not, try this:

sudo rm -rf /var/www/html/admin
sudo git clone https://github.com/pi-hole/AdminLTE.git /var/www/html/admin

I changed the theme to a black theme once.

Tried your solution, got another Error: unable to resole host pi-hole

That's a different situation where you Pi-hole can't seem to reach the Internet. Check your gateway is set properly

gateway, /etc/hostname and /etc/hosts are all correct. But the error still occurs

What does host pi-hole.net return?

pihole.net has address

These two things seem to contradict each other...

But looking at it now, my commands don't go to pi-hole.net; you are just downloading the repo directly from GitHub:

sudo rm -rf /var/www/html/admin
sudo git clone https://github.com/pi-hole/AdminLTE.git /var/www/html/admin

Alright so the previous error came when i tried to delete the old directory. And funny enough i could just download the repository anyway.

After that i tried to install pi-hole again and it stopped at the same error again: Could not update local repository. Contact Support.

At this point im thinking about a full reset of the pi.

Give it a shot if you're able to.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.