Frustrating fresh pihole installation, no internet

Expected Behaviour:

Pihole working as dns server

Actual Behaviour:

Devices cannot access internet through Pihole

Debug Token:


I am having trouble getting pihole to work. The installation has been anything but "easy."

The steps I have had to take to get the point I am at are as follows:

  1. I installed pihole using the curl link without a hitch. Used the default settings including the static IP address that my router gives my pi. This killed internet to my pi and obviously any device that used it as a dns.

  2. To attempt to fix the internet I was able to edit /etc/network/interfaces to contain the static ip address of the pi that the router sets. I am not sure if or why this is neccesary as the router gives it a static ip but it no contains the following:

auto eth0
iface eth0 inet static

  1. With the internet not working and more googling I discovered if I edited /etc/resolv.conf which contains "nameserver" to contain:


I could then connect to the internet on the pi.

  1. After restarting the device the resolv.conf got overwritten (which is apparently common) so after trying many other things the solution I found was to edit /etc/dnsmasq.conf and add the dns servers there, it now contains:


  1. With the internet working through a restart robustly, I now attempted to figure out why devices connected to the pihole did not connect to the internet. When I ran the admin page of the pihole I noticed that had red dot next to the dns service. After more googling I found out that if dnsmasq is not updated with the new version of pihole you need to remove "log-queries=extra" from /etc/dnsmasq.d/01-pihole.conf. This fixed the problem even though I do have the new version of dnsmasq. So no idea why it is needed, but moving on.

  2. The admin gui also had a red dot next to FTL, after more googling I discovered that you can restart the service using "sudo service pihole-FTL restart." Annoyingly this is neccesary every time I restart the pi, but for now I continued on.

The gui now shows everything is running, but still no clients connected the pi can connect to the internet. I moved on the the pihole-d text. This showed some red text that I tried to look into.

No matter my attempts and hours I cannot get the thing to work. Everything can ping everything else including domains and ip addresses, but still not progress.

As you can see the pihole installation has been anything but easy for me, so I am finally about to give up and figured I would see if I could get any help.

My debug token is: 19780xehwj

Thank you for any advice, and hopefully I can get this working!

What are the entry of your dhcp settings from your router? Whenmyour router is the dhcp server, you have to set your pihole as the dns server. In your pihole webinterface you have to set the router as upstream dns

I'm not entirely sure what you mean by set router as upstream dns in the web interface, wouldn't that mean there is no connection to the outside world?

I was testing this the whole time a manual dns server on my phone (so I did not have to take the internet down for the whole house.) I just tried after all the steps I followed earlier to set the router to my raspberry pi as the dns, and it is now working.

Fundamental question: is it mandatory to set the router settings to used pihole as dns? you cannot set a single device to manually use the pihole as dns?

It seems like the pihole is now working, except for a few things:

  1. There is nothing is query log, and graphs show nothing.

  2. I still need to have log-queries=extra removed for the dns to work at all. Why is this, if my dnsmasq is up to date?

  3. I need to restart FTL everytime I restart the raspberry pi.

  4. my debug shows that my gateway is not responding to pings. even though i can obviously ping with no problem.

  5. There are two more errors in the debug that seem like non issues, but I want to be sure. There is a IPV6 ip address mismastch error and X-Header mismatch

New debug token is 9pgq1ndlwc.

hopefully I can ignore the minor issues and get the web interface working properly. Thanks again for the help!

My apologies for your frustrations. We ran into some issues for Jessie users with the latest release. You have two options available:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.