Finding Pi-hole IP addresses after v5.4 update

Okay, you may have to tell me more about what is not working. Everything seems fine from your debug log. Well, except

   2021-09-30 21:15:00: (mod_fastcgi.c.421) FastCGI-stderr: PHP Warning:  syntax error, unexpected '(' in /etc/pihole/pihole-FTL.conf on line 4

You disabled blocking

*** [ DIAGNOSING ]: Setup variables
    BLOCKING_ENABLED=false

Add:

You should remove the duplicate entries from /etc/pihole/setupVars.conf

1 Like

Nope - seems like the branch switch did it. Tested it two more times now. After branch switch pihole is disabled by default. pihole enable took care of it, too easy...

Current situation related to the original issue of this topic:

  1. With FTL version is release/v5.10.2 vDev-ccf8d15 (Latest: v5.10.1) AND REPLY_ADDR4 being set: everything´s working (pi.hole is correctly resolved)
  2. With FTL version is release/v5.10.2 vDev-ccf8d15 (Latest: v5.10.1) and WITHOUT REPLY_ADDR4 being set: *** no internal type for both IPv4 and IPv6 Addresses (A+AAAA) entries for pi.hole available. for Windows client
  3. With FTL version is v5.10.1 (Latest: v5.10.1) WITH or WITHOUT REPLY_ADDR4 being set: *** no internal type for both IPv4 and IPv6 Addresses (A+AAAA) entries for pi.hole available. for Windows client

Regarding 2.:

Sep 30 21:27:39 dnsmasq[30620]: query[A] pi.hole from 192.168.0.56
Sep 30 21:27:39 dnsmasq[30620]: Pi-hole hostname pi.hole is Pi-hole hostname
Sep 30 21:27:39 dnsmasq[30620]: query[AAAA] pi.hole from 192.168.0.56
Sep 30 21:27:39 dnsmasq[30620]: Pi-hole hostname pi.hole is Pi-hole hostname

So Fix virtual interface address determination by DL6ER · Pull Request #1170 · pi-hole/FTL · GitHub obviously didn´t work (for me) :frowning:

That´s a ( within a comment line (# comment with a (here and a ) there), not sure where´s the problem with it (but that´s a side issue I don´t really care about, just FYI maybe it´s interesting to you).

DNS_BOGUS_PRIV=true
DNS_FQDN_REQUIRED=true

THX for that too, no idea why those guys exist multiple times in that file. Little extra benefit having devs and experts looking at my debug log. I like :smiley:

PHP doesn't interpret # as comments but only lines with ; FTL accepts both.

Could you please add

DEBUG_QUERIES=true
DEBUG_NETWORKING=true

to /etc/pihole/pihole-FTL.conf and send me the snippet from both /var/log/pihole.log and /var/log/pihole-FTL.log when doing the nslookup ?

Sent by PM.

Can´t wait to switch back to master branch.

When will FTL 5.10.2 be released for master branch? @DL6ER

It is already.

Took my instance a while to see it (pihole -v still showed 5.10.1 as latest version). I´ll provide another debug log now as requested by DL6ER.

By the way: those two lines are meanwhile in /etc/pihole/setupVars.conf again 2 times, don´t know what action added them. Just FYI, I personally don´t really care -.-

Please post the output of pihole -v

I switched back to master branch and updated meanwhile, all good on this front.

  Pi-hole version is v5.5 (Latest: v5.5)
  AdminLTE version is v5.7 (Latest: v5.7)
  FTL version is v5.10.2 (Latest: v5.10.2)

Thanks for letting us know. That's a bug. I'll fix that.

Thanks, we had a bit of conversation over there and I've also checked the configuration which is plain standard. This means FTL is unable to obtain any kind of information about the interfaces connected to your system. On none of the test systems we used during development, we've seen such a behavior which leads me to the question:

On which hardware is this system running? Do you use any kind of virtualization?


edit This is very likely the same issue:

In addition, I'd like to ask you to run

pihole checkout ftl tweak/iface_detection

and repeat the nslookup and send me again what you see in pihole-FTL.log (pihole.log not needed).

I added more debugging output and this should hopefully reveal why your interface is not correctly being detected here.

Raspberry Pi 4 on Raspbian. No virtualization. Only „special“ config as mentioned is a virtual interface on top of eth0 which runs a separate IP address Pi-Hole is bind to.

Sent via PM.

Is this really resolved with the current version? I'm currently running:

Docker Tag 2021.10
Pi-hole v5.5
FTL v5.10.2
Web Interface v5.7

When I'm configuring the virtual eth0:0 IP for IPV4_ADDRESS in setupVars.conf to as well as for REPLY_ADDR4 in pihole-FTL.conf, the latter still get's overwritten with the IP of the physical eth0: interface on every pihole restart (in my case the docker container).

There's at least one more "not so special" use case for using virtual interfaces: Running two (or more) pihole instances together with keepalived for failover. And this is exactly, why I'm running into this issue.

And it's a problem, because the failover doesn't work, if pihole advertises the physical IP instead of the virtual IP to clients. When the master node is gone, the virtual IP switches over to the backup node, but as clients got the physical IP as their DNS setting from the master node (which is down), they still try to reach the master node for name resolution. This would only work again, if the client re-connects or if the dhcp lease has to be renewed, in which case the backup node pushes it's physical IP to clients as the primary DNS.

That post you quoted was 20 days and many test and debug steps ago.

But yes, currently with FTL 5.10.2 and parameter set in FTL config the virtual interface IP of pihole is correctly resolved.

Anyway, this should work automatically without the parameter set manually, that’s why DL6ER is still investigating (via PM).