Failed installation

Expected Behaviour:

After installing Pi-hole, I should be able to use pihole commands in bash on the Pi, access the web ui by typing http://IP/admin/, and use it as my PC's DNS server.

Actual Behaviour:

None of these things work.

Debug Token:

command not found - I don't think the installation is completing.

It looks like an installation screen pops up and the disappears at the last minute, and then the installation stops. I did sudo apt-get upgrade and sudo apt-get update first.

Will you please update your system prior to running the install? If Pi-hole can't install the packages it needs or fails to for some reason, we stop the installer so you don't end up with a broken install.

Thanks for the reply. I did actually do sudo apt-get update; sudo apt-get upgrade on my Raspberry Pi 3 before installing. I'm using OSMC which is Raspbian kitted out for Kodi. Could it be that some things are missing. Is there a manual way to install anything Pi-hole might be dependent on first. Thanks!

Can you upload your install log to our tricoder server? This may offer some clues. you can find instructions for doing so under the Alternative section on this link:

Thanks again for the reply. I'm not sure if this is exactly what you wanted but I hope it can help! I generated a log of everything I could directly from OSMC: LINK REMOVED

Sadly, that information isn't really useful to us since it's not the Pi-hole install log.

Apologies for the misunderstanding. I am very new to CLI and linux and am trying to learn. So there is an install log generated by Pi-hole as it is installed? If you could let me know where in the file system this would be saved, I can take the contents and upload it for you guys to take a look at.

I am unable to use the tricorder (heh) functionality as the installation did not correctly complete, so I am unable to use pihole commands in bash.

I also found this Reddit thread about what I'm trying to do, but it's a little old so might not be completely relevant, but thought I'd post it as well:

Thanks for your support guys!

I have done a bit more fiddling and was able to find out why it wasn't installing. I disabled the web admin interface during setup and the program installed successfully. Does this mean there may be some dependency that the installer assumes it has but then doesn't and fails?

I chose "no" for installing the web admin interface, and once it completed it told me where I could find the log, so I then tried updating the installation to include the web interface and when the installation stopped I copied the log. This is what it said, nothing particularly helpful by the looks of it! I don't think it's any different than from when I checked it right after the install without the web interface worked.

Can you share the new install log? We might see something you missed. It's located at /etc/pihole/install.log

Apologies, I did mean to upload it but missed the link! It's now there.

I used this guide to get the webui working:

I had to install lighttpd first though! Once it was all working, I tried running the installer again and this time I chose to install the web UI. Well, it stopped during install again and I had to restart lighttpd to get it to work again. Odd!

Just did pihole -d and it gave me this token: bxftdk8wal

I'm hoping this will help, please let me know if there's any further information you need!

Also, perhaps I should create a new topic, but the blacklist will not add anything at the moment. I'm not sure if this is related the the aforementioned issues or not.

Sorry, I neglected to mention /etc/pihole/install.log was the file I was originally requesting.

Your debug log indicates Pi-hole is configured to send queries to This often works, but it's typically configured to go to the IP of the Pi-hole itself.

connmand may also be causing issues if it's interfering with network connections.

Your gateway is also not responding, which doesn't always mean it's not working, but it's possible. It could just not be replying to pings.

So still several issues it seems.

What are the exact problems you are running into now that you've made more progress?

So just to make sure here is a screenshot of /etc/pihole/install.log from Putty:
Here's a pastebin of the same info: :::::: Installing scripts from /etc/.pihole... done.:::::: Installing conf -

As for issues:

It seems I'm not able to change the Pi-holes address form in the admin settings page, but isn't this essentially the same as LOCALHOST for this case? If not, is there I file I can manually edit to change this?

On the status up on the top right, it does say status: unknown a lot of the time:
I did notice it said active at one point but more often than not, it's unknown.

In the query log, I am also seeing a request to github from the raspberry pi pretty much every second, if not multiple times per second. Seems a bit excessive, but I can't say for sure if that's from Pi-hole or something else (the Pi is pretty much just OSMC with Transmission installed though). Looks a lot like this: Constant requests to from Pi-Hole device

The only other thing I've noticed is that adding things to the blacklist menu just doesn't work, nor does clicking the blacklist button on the query log. Maybe the permissions on some file aren't right?

According to your settings, it shouldn't have installed the web interface because you chose not to (That's why the IP is set to


Did you originally install the web interface, then reconfigure it to not install it?

Run pihole -r to reconfigure Pi-hole with the device's IP address, and choose to install the web interface.

As said, I wasn't able to get the installation to complete unless I said "no" to the web interface. I Then re-enabled it using the second set of theps on this webpage:

I've just done it using the command you gave and it seems to have reconfigured correctly. I think blocking is now working but will have a fiddle to make sure.

That tutorial is outdated, and the root of the problem seems to be when the installer is unable to install the web interface. Do you have the installer output when it failed to complete the install when you selected the web interface?

Unfortunately there is no output when it quits unexpectedly. I confirmed this by comparing the log before and after doing an install that would fail as described, and noting that there was no change.

Try removing the web interface files (/var/www/html/admin) and running the install again.
If that doesn't work, then share the output of installing via curl -sSL | sudo bash -x