Error running pihole update - lighttpd will not start

v4-0

#1

hi, when running pihole -up from version 3 to 4 it fails, without an error message i could interpret.

pihole -up

https://pastebin.com/HCecfNig

  • running pihole in lxc container (proxmox)

Expected Behaviour:

it updates and runs like charm

Actual Behaviour:

fails update

Debug Token:

before update: dvdz4gb8wx

after update: 89w12qjlym


#2

Have you in past made any changes such as themeing to your lighttpd install?


#4

no, i didn’t touch lighttpd, i only changed the dnsmasq ttl value.


#5

There are a few quick things we can try. Your debug log shows you fully at V4, but none of the Pi-Hole services are shown as running.

pihole -r and select repair option

reboot the pi


#6

pihole -r

already done that

reboot the pi

i run lxc container in proxmox

because i have a snapshot i can try whatever u want :wink:


#7

I should have noticed not on a Pi. My error.


#8

debug token for pihole -r : hx7jf3nkmr

after repair i have to uninstall dhcpd, because it breaks networking on lxc containers…

debug token after reboot and failed upgrade: 6j1t0ogf62

edit: just tested, fresh install works, so there shouldn’t be a compatibility problem.


#10

Is your problem resolved?


#11

No I meant a fresh install of pihole works on a new deployed lxc container.

Update still fails on my existing Installations.


#12

I believe your best approach may be to continue with what worked for you, a fresh install on the other containers. That is likely to be a quicker solution than attempting to repair your existing installation.

If you go this route, use the teleport to export you current settings, which you can then transfer to the new installation.