Error: Neither IPv4 or IPv6 selected

This is my docker-compose.yml

version: "3"

# More info at https://github.com/pi-hole/docker-pi-hole/ and https://docs.pi-hole.net/
services:
  pihole:
    container_name: pihole
    image: pihole/pihole:latest
    ports:
      - "53:53/tcp"
      - "53:53/udp"
      - "67:67/udp"
      - "80:80/tcp"
      - "443:443/tcp"
    environment:
      TZ: 'America/Los_Angeles'
      # WEBPASSWORD: 'set a secure password here or it will be random'
    # Volumes store your data between container upgrades
    volumes:
      - './etc-pihole/:/etc/pihole/'
      - './etc-dnsmasq.d/:/etc/dnsmasq.d/'
    # Recommended but not required (DHCP needs NET_ADMIN)
    #   https://github.com/pi-hole/docker-pi-hole#note-on-capabilities
    cap_add:
      - NET_ADMIN
    restart: unless-stopped

When I run sudo docker exec -it pihole /bin/bash and then run pihole -r I get:

root@2cb25b4ecc9f:/# pihole -r

  [✓] Root user check

        .;;,.
        .ccccc:,.
         :cccclll:.      ..,,
          :ccccclll.   ;ooodc
           'ccll:;ll .oooodc
             .;cll.;;looo:.
                 .. ','.
                .',,,,,,'.
              .',,,,,,,,,,.
            .',,,,,,,,,,,,....
          ....''',,,,,,,'.......
        .........  ....  .........
        ..........      ..........
        ..........      ..........
        .........  ....  .........
          ........,,,,,,,'......
            ....',,,,,,,,,,,,.
               .',,,,,,,,,'.
                .',,,,,,'.
                  ..'''.

  [✓] Update local cache of available packages
  [i] Existing PHP installation detected : PHP version 7.0.33-0+deb9u8
--title Existing Install Detected! --menu \n\nWe have detected an existing install.\n\nPlease choose from the following options: \n(You will remain on the same version) 24 70 2 Repair This will retain existing settings Reconfigure This will reset your Pi-hole and allow you to enter new settings.
  [✓] Disk space check

  [✗] Checking apt-get for upgraded packages
      Kernel update detected. If the install fails, please reboot and try again
  [i] Installer Dependency checks...
  [✓] Checking for dhcpcd5
  [✓] Checking for git
  [✓] Checking for iproute2
  [✓] Checking for whiptail
  [✓] Checking for dnsutils

  [✓] Supported OS detected
  [i] SELinux not detected
--msgbox --backtitle Welcome --title Pi-hole automated installer \n\nThis installer will transform your device into a network-wide ad blocker! 24 70
--msgbox --backtitle Plea --title Free and open source \n\nThe Pi-hole is free, but powered by your donations:  https://pi-hole.net/donate/ 24 70
--msgbox --backtitle Initiating network interface --title Static IP Needed \n\nThe Pi-hole is a SERVER so it needs a STATIC IP ADDRESS to function properly.

In the next section, you can choose to use your current network settings (DHCP) or to manually edit them. 24 70
--separate-output --menu Select Upstream DNS Provider. To use your own, select Custom. 24 70 7 Google (ECS)  OpenDNS (ECS)  Level3  Comodo  DNS.WATCH  Quad9 (filtered, DNSSEC)  Quad9 (unfiltered, no DNSSEC)  Quad9 (filtered + ECS)  Cloudflare  Custom 
  [i] Using upstream DNS:  ()
--separate-output --checklist Pi-hole relies on third party lists in order to block ads.\n\nYou can use the suggestions below, and/or add your own after installation\n\nTo deselect any list, use the arrow keys and spacebar 24 70 5 StevenBlack StevenBlack's Unified Hosts List on MalwareDom MalwareDomains on
--separate-output --checklist Select Protocols (press space to toggle selection) 24 70 2 IPv4 Block ads over IPv4 on IPv6 Block ads over IPv6 on
  [i] IPv4 address: 
  [i] IPv6 address: 
  Error: Neither IPv4 or IPv6 selected

if I run ifconfig on my ubuntu server, this is my network interface:

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.7.8  netmask 255.255.255.0  broadcast 192.168.7.255
        inet6 fe80::aaa1:59ff:fe1f:f832  prefixlen 64  scopeid 0x20<link>
        ether a8:a1:59:1f:f8:32  txqueuelen 1000  (Ethernet)
        RX packets 380278  bytes 290816088 (290.8 MB)
        RX errors 0  dropped 4  overruns 0  frame 0
        TX packets 133071  bytes 33096167 (33.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xa1200000-a1220000  

any ideas? :confused:

if I click "Generate debug log" from the admin (accessed by going to my servers IP + /admin/) it never generates a log... weird!

when i run pihole -d from the terminal i get this:

root@2cb25b4ecc9f:/# pihole -d

This process collects information from your Pi-hole, and optionally uploads it to a unique and random directory on tricorder.pi-hole.net.

The intent of this script is to allow users to self-diagnose their installations.  This is accomplished by running tests against our software and providing the user with links to FAQ articles when a problem is detected.  Since we are a small team and Pi-hole has been growing steadily, it is our hope that this will help us spend more time on development.

NOTE: All log files auto-delete after 48 hours and ONLY the Pi-hole developers can access your data via the given token. We have taken these extra steps to secure your data and will work to further reduce any personal information gathered.

*** [ INITIALIZING ]
[i] 2020-10-16:18:17:21 debug log has been initialized.

*** [ INITIALIZING ] Sourcing setup variables
[i] Sourcing /etc/pihole/setupVars.conf...

*** [ DIAGNOSING ]: Core version
[i] Core: v5.1.2 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Remotes: origin	https://github.com/pi-hole/pi-hole.git (fetch)
             origin	https://github.com/pi-hole/pi-hole.git (push)
[i] Branch: master
[i] Commit: v5.1.2-0-g6b536b7

*** [ DIAGNOSING ]: Web version
[i] Web: v5.1.1 (https://discourse.pi-hole.net/t/how-do-i-update-pi-hole/249)
[i] Remotes: origin	https://github.com/pi-hole/AdminLTE.git (fetch)
             origin	https://github.com/pi-hole/AdminLTE.git (push)
[i] Branch: master
[i] Commit: v5.1.1-0-ga03d1bdd

*** [ DIAGNOSING ]: FTL version
[✓] FTL: v5.2

*** [ DIAGNOSING ]: lighttpd version
[i] 1.4.45

*** [ DIAGNOSING ]: php version
[i] 7.0.33

*** [ DIAGNOSING ]: Operating system
[✓] Distro:  Debian
[✓] Version: 9

*** [ DIAGNOSING ]: SELinux
[i] SELinux not detected

*** [ DIAGNOSING ]: Processor
[i] x86_64

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the eth0 interface:
   172.18.0.2/16 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway: 172.18.0.1
   * Pinging 172.18.0.1...
[✓] Gateway responded.

*** [ DIAGNOSING ]: Ports in use
[53] is in use by pihole-FTL
[53] is in use by pihole-FTL
[4711] is in use by pihole-FTL

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] netfilxca.com is 0.0.0.0 via localhost (127.0.0.1)
[✓] netfilxca.com is 0.0.0.0 via Pi-hole (0.0.0.0)
[✓] doubleclick.com is 172.217.3.206 via a remote, public DNS server (8.8.8.8)

*** [ DIAGNOSING ]: Pi-hole processes
[✗] lighttpd daemon is inactive
[✗] pihole-FTL daemon is inactive

*** [ DIAGNOSING ]: Setup variables
    BLOCKING_ENABLED=true
    QUERY_LOGGING=true
    INSTALL_WEB_SERVER=true
    INSTALL_WEB_INTERFACE=true
    LIGHTTPD_ENABLED=
    IPV4_ADDRESS=0.0.0.0
    IPV6_ADDRESS=
    DNS_BOGUS_PRIV=
    DNS_FQDN_REQUIRED=
    DNSSEC=
    CONDITIONAL_FORWARDING=
    CONDITIONAL_FORWARDING_IP=
    CONDITIONAL_FORWARDING_DOMAIN=
    CONDITIONAL_FORWARDING_REVERSE=
    PIHOLE_DNS_1=8.8.8.8
    PIHOLE_DNS_2=8.8.4.4
    PIHOLE_INTERFACE=eth0

*** [ DIAGNOSING ]: Dashboard and block page


and it then never continues!

Why are you running that command inside a container?

Edit: That command won't work inside the container, there's no need to run it. Please explain what you are trying to achieve.

I was trying to run the pihole repair command to see if that could diagnose what the issue was.

What issue?