Enabling Unbound-Control: get error

Currently trying to enable unbound-ctonrol. When I enter the command:

sudo -u unbound unbound-control-setup

end up with error message:

cannot create server.cnf: Permission denied

Try run it as root instead of the unbound user eg:

sudo unbound-control-setup

Worked for below:

FYI:

$ man unbound-control
[..]
SET UP
       The  setup  requires a self-signed certificate and private keys for
       both the server and client.  The script unbound-control-setup  gen‐
       erates  these  in  the default run directory, or with -d in another
       directory.

Where did you get that -u unbound from?

That’s what was listed on the Unbound documentation. However, I think the issue was with a custom AppArmor profile, that came installed with Unbound. Running as root did work however.

The real issue appeared to be I somehow removed the reference to remotecontrol.conf from the unbound.conf file, meaning I couldn’t use the remote-control feature.

More specific pls?

EDIT: Never mind, found it: