# Dnsmasq Service Not Starting

**URL:** <https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738>\
**Category:** Help\
**Created:** [July 7, 2018, 8:42pm UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738 "2018-07-07T20:42:50Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![xreyuk](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/x/b2d939/32.png) [@xreyuk](https://discourse.pi-hole.net/u/xreyuk)\
**Post date:** [July 7, 2018, 8:42pm UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738/1 "2018-07-07T20:42:50Z")

</div>

#### Please follow the below template, it will help us to help you!

## Expected Behaviour:

_[dnsmasq should start]_

## Actual Behaviour:

_[dnsmasq doesn't restart]_

## Debug Token:

_[Debug Token: habssn14ak]_

Basically I cannot get dnsmasq to start.

Doing a service dnsmasq status brings the following:

● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server  
Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled)  
Drop-In: /run/systemd/generator/dnsmasq.service.d  
└─50-dnsmasq-$named.conf, 50-insserv.conf-$named.conf  
Active: failed (Result: exit-code) since Sat 2018-07-07 21:34:51 BST; 2min 30s ago  
Process: 6485 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=1/FAILURE)  
Process: 6483 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)

I have no idea why this started, when I became aware of the issue the pi-hole had been running fine for a while and just stopped working, that's when I checked and dnsmasq wasn't running.

I've tried multiple things, including repairing pi-hole and downloading the earlier FTL versions as I'm on Debian Jessie.

Thanks again.

---

<div class="post-metadata">

**Author:** ![Mcat12](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/mcat12/32/20_2.png) [@Mcat12](https://discourse.pi-hole.net/u/Mcat12)\
**Post date:** [July 7, 2018, 9:33pm UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738/2 "2018-07-07T21:33:00Z")

</div>

Is that the full output of `sudo service dnsmasq status -l`

---

<div class="post-metadata">

**Author:** ![xreyuk](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/x/b2d939/32.png) [@xreyuk](https://discourse.pi-hole.net/u/xreyuk)\
**Post date:** [July 8, 2018, 11:09am UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738/3 "2018-07-08T11:09:08Z")

</div>

This is the output of sudo service dnsmasq status -l

> dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server  
> Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled)  
> Drop-In: /run/systemd/generator/dnsmasq.service.d  
> └─50-dnsmasq-$named.conf, 50-insserv.conf-$named.conf  
> Active: failed (Result: exit-code) since Sat 2018-07-07 22:41:49 BST; 13h ago  
> Process: 956 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=1/FAILURE)  
> Process: 859 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)

> Jul 07 22:41:47 NAS dnsmasq[859]: dnsmasq: syntax check OK.  
> Jul 07 22:41:49 NAS dnsmasq[956]: dnsmasq: junk found in command line  
> Jul 07 22:41:49 NAS systemd[1]: dnsmasq.service: control process exited, code=exited status=1  
> Jul 07 22:41:49 NAS systemd[1]: Failed to start dnsmasq - A lightweight DHCP and caching DNS server.  
> Jul 07 22:41:49 NAS systemd[1]: Unit dnsmasq.service entered failed state.

I have since tried uninstalling and re-installing pi-hole, then following this post: [How do I revert to a previous version of Pi-hole?](https://discourse.pi-hole.net/t/how-do-i-revert-to-a-previous-version-of-pi-hole/7168) to do the downgrade, as I am still on Debian Jessie, and I still have the exact same issue.

---

<div class="post-metadata">

**Author:** ![Mcat12](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/mcat12/32/20_2.png) [@Mcat12](https://discourse.pi-hole.net/u/Mcat12)\
**Post date:** [July 8, 2018, 3:55pm UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738/4 "2018-07-08T15:55:52Z")

</div>

This is a Debian issue: [https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=860064](https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=860064)

Currently, the solution seems to be removing the `dns-root-data` package.

---

<div class="post-metadata">

**Author:** ![nevillebartos](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/n/ecc23a/32.png) [@nevillebartos](https://discourse.pi-hole.net/u/nevillebartos)\
**Post date:** [July 13, 2018, 9:26am UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738/5 "2018-07-13T09:26:52Z")

</div>

> [@Mcat12](#):
>
> dns-root-data

This was the exact problem that I was having running

```
sudo apt-get --purge remove dns-root-data

```

fixed it up like a charm.

---

<div class="post-metadata">

**Author:** ![system](https://discourse.pi-hole.net/uploads/default/original/3X/7/c/7c8792f649eeb921c5d2b4c41564ffa873d9a2b8.png) [@system](https://discourse.pi-hole.net/u/system)\
**Post date:** [August 3, 2018, 9:38am UTC](https://discourse.pi-hole.net/t/dnsmasq-service-not-starting/10738/6 "2018-08-03T09:38:26Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
