Dnsmasq or starting - Ubuntu


#1

I just found this thread. I have same issue.
I want to know that once the problem is fixed that it will be updated in this thread.


Dnsmasq fails on Pi-hole 3.3
#2

Hello
I am relatively new to pi-hole. But hooked now.
I run it on my ubuntu server (not the actual raspberry pi). I had it working on 17.10. I had to re-start the dnsmasq everytime I rebooted the machine. But that’s past.
I had to re-install the os. So, I installed 18.04 64 bit.
And now, once I install the pi-hole, it doesn’t block anything (if I don’t reboot my machine). Soon as I reboot, there is no internet. And the dnsmasq isn’t running. The only way to get internet working is to change the nameserver in /etc/resovle.conf to opendns or google or something other than local host.
Now, I found this thread and tried to use the older version but that doesn’t work and has same symptoms.
So I generated the debug token : “9h5jyaddvg” .

Any help is much appreciated.

9h5jyaddvg


#3

Can you try a pihole -r > Repair?


#4

Yes. I did repair. Didn’t work.
I uninstalled it (from uninstall script). And then got 3.2.1 version and did fresh install. Same results. I ran repair and reconfigure again as well. No change.

Edit:
I should have noted that: the pihole works but the console doesn’t (need to reboot after install). I don’t really need console right away, I can wait for next version . But the host (where it’s installed) can’t access internet.
And I use that computer as multipurpose server, so it needs internet.


#5

Make a new debug token.


#6

I was out of town for a few days.
new token : “i29a2cj88i”
Also, few things to note:
I had to re-install pi- hole, I installed latest. Now it blocks some ads but most show up.
I do nslookup for 888.com and it returns local host. But also shows “non authoritative” to be real ip of the site.
In the past most of the ads from my android phone apps were blocked and now they show up. (My regular browsers if I diable my ad block add ons, the ads show up)
Thank you for your help.