# Dnsmasq: failed to create listening socket for port 53: Permission denied

**URL:** https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436
**Category:** Help
**Created:** [January 25, 2019, 3:31am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436 "2019-01-25T03:31:34Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 25, 2019, 3:31am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/1 "2019-01-25T03:31:34Z")

</div>

How to solve this problem? There is no software using port 53. And my os is Raspbian  
root@raspberrypi:/etc/init.d# ./pihole-FTL start  
Not running

dnsmasq: failed to create listening socket for port 53: Permission denied  
And I save my Upstream DNS Servers settings, The pihole-FTL will be offline, I must start it manually.

---

<div class="post-metadata">

### Author: ![jfb](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/jfb/32/4332_2.png) [@jfb](https://discourse.pi-hole.net/u/jfb)
#### Post date: [January 25, 2019, 3:40am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/2 "2019-01-25T03:40:19Z")

</div>

In V4.0, dnsmasq is embedded in pihole-FTL, and dnsmasq no longer runs as a separate process. The debug log will show dnsmasq as either failed or inactive. Process pihole-FTL should be shown running on port 53.

> **[DNS resolver - Pi-hole documentation](https://docs.pi-hole.net/ftldns/dns-resolver/)**

Please generate a debug log, upload it and post the token.

If you are unable to upload the debug log, then change the Pi nameserver as follows and then generate and upload the debug log.

```
sudo nano `/etc/resolv.conf`

edit `127.0.0.1` to `9.9.9.9` or your preferred third party DNS service

save and exit

```

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 25, 2019, 3:52am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/4 "2019-01-25T03:52:14Z")

</div>

My ISP Blocked the upload server , so I upload the log here.  
[pihole\_debug-sanitized.txt](https://discourse.pi-hole.net/uploads/default/original/2X/6/612b4955fd06d7abceab216058e10b9262fec189.txt) (19.0 KB)

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 25, 2019, 3:54am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/5 "2019-01-25T03:54:41Z")

</div>

Itried again, My token is d43zia4b45

---

<div class="post-metadata">

### Author: ![Mcat12](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/mcat12/32/20_2.png) [@Mcat12](https://discourse.pi-hole.net/u/Mcat12)
#### Post date: [January 25, 2019, 5:25am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/6 "2019-01-25T05:25:57Z")

</div>

You should use the `service` commands to start and stop FTL:

```auto
sudo service pihole-FTL start
sudo service pihole-FTL stop

```

---

<div class="post-metadata">

### Author: ![jfb](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/jfb/32/4332_2.png) [@jfb](https://discourse.pi-hole.net/u/jfb)
#### Post date: [January 25, 2019, 4:49pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/7 "2019-01-25T16:49:25Z")

</div>

> [@wxf26054](#):
>
> There is no software using port 53

Your debug log shows that pihole-FTL is running on port 53:

```
*** [DIAGNOSING]: Ports in use
...
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
...
[*:80] is in use by lighttpd
[*:53] is in use by pihole-FTL
[*:53] is in use by pihole-FTL
[127.0.0.1:4711] is in use by pihole-FTL
[[::1]:4711] is in use by pihole-FTL
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd
[*:80] is in use by lighttpd

```

and shows that Pi-Hole is properly resolving DNS queries:

```
*** [DIAGNOSING]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] ad.doubleclick.net.28751.9225.302br.net is 192.168.10.30
0.0.0.0 via localhost (127.0.0.1)
[✓] ad.doubleclick.net.28751.9225.302br.net is 192.168.10.30 via Pi-hole (192.168.10.30)
[✓] doubleclick.com is 216.58.200.238 via a remote, public DNS server (8.8.8.8)

```

Let's double check the processes running on ports used by Pi-Hole. Please post the output of this command run from the Pi terminal:

`sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'`

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 26, 2019, 11:46pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/8 "2019-01-26T23:46:19Z")

</div>

root@localhost:/home/user# /etc/init.d/pihole-FTL start  
Not running

dnsmasq: failed to create listening socket for port 53: Permission denied

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 26, 2019, 11:48pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/9 "2019-01-26T23:48:10Z")

</div>

```
Proto Recv-Q Send-Q Local Address Foreign Address PID/Program name
tcp 0 0 127.0.0.1:4711 0.0.0.0:* LISTEN 6956/pihole-FTL
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 6956/pihole-FTL
tcp6 0 0 ::1:4711 :::* LISTEN 6956/pihole-FTL
tcp6 0 0 :::80 :::* LISTEN 2320/apache2
tcp6 0 0 :::53 :::* LISTEN 6956/pihole-FTL
udp 0 0 0.0.0.0:53 0.0.0.0:* 6956/pihole-FTL
udp6 0 0 :::53 :::* 6956/pihole-FTL

```

pihole-FTL process is started by manually

---

<div class="post-metadata">

### Author: ![DanSchaper](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/danschaper/32/91_2.png) [@DanSchaper](https://discourse.pi-hole.net/u/DanSchaper)
#### Post date: [January 27, 2019, 10:22am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/10 "2019-01-27T10:22:10Z")

</div>

FTL will start when the system boots, since it's a necessary system function. If you want to only manually start `pihole-FTL` which is highly unadvised and not a supported runtime, then you need to stop `pihole-FTL` from starting on boot. Do not run `./pihole-FTL` from `/etc/init.d` or from it's location in `/usr/bin`. Run `sudo service pihole-FTL start` or `sudo systemctl start pihole-FTL` only. The init scripts handle the creation of many required files and nodes that manually starting the process will not create.

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 11:58am UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/11 "2019-01-28T11:58:18Z")

</div>

I tried, and it always inform me like this below.

root@localhost:/home/user# /etc/init.d/pihole-FTL start  
Not running

dnsmasq: failed to create listening socket for port 53: Permission denied

---

<div class="post-metadata">

### Author: ![DanSchaper](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/danschaper/32/91_2.png) [@DanSchaper](https://discourse.pi-hole.net/u/DanSchaper)
#### Post date: [January 28, 2019, 12:01pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/12 "2019-01-28T12:01:48Z")

</div>

> [@DanSchaper](#):
>
> Run `sudo service pihole-FTL start` or `sudo systemctl start pihole-FTL` only.

Do not run /etc/init.d/pihole-FTL start

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:05pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/13 "2019-01-28T12:05:03Z")

</div>

Still output this information  
root@localhost:/home/user# sudo /etc/init.d/pihole-FTL start  
Not running

dnsmasq: failed to create listening socket for port 53: Permission denied  
Is the Debian OS is not compatible with pi-hole? I used pihole in Ubuntu with no errors before.

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:09pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/15 "2019-01-28T12:09:11Z")

</div>

There is no any original dnsmasq software exsits, and no other software listenning on port 53.

---

<div class="post-metadata">

### Author: ![DanSchaper](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/danschaper/32/91_2.png) [@DanSchaper](https://discourse.pi-hole.net/u/DanSchaper)
#### Post date: [January 28, 2019, 12:09pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/16 "2019-01-28T12:09:28Z")

</div>

Permission is denied because pihole-FTL is not being invoked correctly. I have given you the proper procedure a few times now. Do not start the pihole-FTL with any command including the directory `/etc/init.d`.

Raspbian Stretch works just fine if you follow directions.

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:13pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/17 "2019-01-28T12:13:07Z")

</div>

It will starts and runs the pihole-FTL process normally by manual.

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:20pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/19 "2019-01-28T12:20:37Z")

</div>

After save this settings, it will execute "pihole restartdns" command, and then "pihole-FTL" will not start. So I must start it by manually.  
And do "sudo service pihole-FTL start" or "sudo /etc/init.d/pihole-FTL start" will not work. It will show the information below:

dnsmasq: failed to create listening socket for port 53: Permission denied

"journalctl -xe" also shows that information above.

---

<div class="post-metadata">

### Author: ![DanSchaper](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/danschaper/32/91_2.png) [@DanSchaper](https://discourse.pi-hole.net/u/DanSchaper)
#### Post date: [January 28, 2019, 12:26pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/21 "2019-01-28T12:26:55Z")

</div>

What is the output from `sudo getcap /usr/bin/pihole-FTL`

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:27pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/22 "2019-01-28T12:27:11Z")

</div>

Yes. So I use sudo systemctl restart pihole-FTL or sudo /etc/init.d/pihole-FTL  
They all will show that information.

If there is no other solution. I must to change the OS to Ubuntu.

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:31pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/24 "2019-01-28T12:31:44Z")

</div>

It'll show pihole-FTL is Offline

---

<div class="post-metadata">

### Author: ![wxf26054](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/wxf26054/32/6285_2.png) [@wxf26054](https://discourse.pi-hole.net/u/wxf26054)
#### Post date: [January 28, 2019, 12:40pm UTC](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436/26 "2019-01-28T12:40:26Z")

</div>

pihole-FTL process is not exist in the process list  
 ![%E5%9B%BE%E7%89%87](https://discourse.pi-hole.net/uploads/default/original/2X/b/b13cb528e856ff7e67f4b8cb95ff751c8e2d1e51.png)

 ![%E5%9B%BE%E7%89%87](https://discourse.pi-hole.net/uploads/default/original/2X/1/100c500ebfef06f0a8a4976ac7cf32c73e185278.png)

[Next page](https://discourse.pi-hole.net/t/dnsmasq-failed-to-create-listening-socket-for-port-53-permission-denied/16436.md?page=2)
