DNS stops after manually adding entries to DHCP list

Please follow the below template, it will help us to help you!

Expected Behaviour:

Moving DHCP lease behavior from DDWRT to piHole. Don’t want to add 20+ listings through the GUI. Manually updated the 04-* file in /etc/dnsmasq.d/ with my entries.

Actual Behaviour:

DNS immediately stops working afterwards. Deleted that file and rebooted and DNS/FTL works again.

Debug Token:

Sorry I’m remote and dont have this

A likely problem is a syntax or line feed/break problem in that file.

I was thinking the same thing but this morning i’ve done some more troubleshooting and i’m still stumped.

I was manually adding in my listings through the GUI … got about halfway through and noticed DNS/FTL had stopped again. I have to delete the conf file and disable DHCP, reboot and DNS works again. I tried manually adding every single entry in again … got through the whole list and everything was still up and running. I rebooted just to be sure all would work and sure enough when it came back up DNS/FTL was borked again. I have to remove the CONF file, disable DHCP and reboot for it to work like normal again. I copied the conf file (which was created when I manually added each entry to the GUI) out of the dnsmasq.d directory and i’m comparing it to the one I added via cmd and they are identical except for a few entries I didnt include. syntax looks legit. Is there a limit to how many hosts you can add or something? I dont understand the correlation between the DHCP static leases and DNS going up / down.

Checking the logs for the error is a much more direct path to find out what the error is:

journalctl -u pihole-FTL --full --no-pager
cat /var/log/pihole-FTL.log
cat /var/log/pihole.log

If you post the configuration file, we can double check.

I replaced the actual hostnames with hostnames below. None of my hostnames have spaces. Some have dashes but no spaces.

cat 04-pihole-static-dhcp.conf

dhcp-host=8C:3B:AD:FB:84:32,10.10.1.1,hostnames
dhcp-host=B8:27:EB:98:75:27,10.10.1.2,hostnames
dhcp-host=18:E8:29:59:95:E2,10.10.1.3,hostnames
dhcp-host=90:4C:E5:31:95:94,10.10.1.4,hostnames
dhcp-host=A0:04:60:DA:3C:CD,10.10.1.6,hostnames
dhcp-host=B8:27:EB:0E:8F:8D,10.10.1.10,hostnames
dhcp-host=D0:E7:82:BC:BD:24,10.10.1.12,hostnames
dhcp-host=00:CE:39:CE:D3:53,10.10.1.13,hostnames
dhcp-host=00:E0:36:D1:D6:3E,10.10.1.14,hostnames
dhcp-host=70:26:05:E9:26:D7,10.10.1.15,hostnames
dhcp-host=C0:33:5E:CE:18:3E,10.10.1.20,hostnames
dhcp-host=E0:31:9E:2D:70:FE,10.10.1.21,hostnames
dhcp-host=5C:52:1E:66:CA:D8,10.10.1.22,hostnames
dhcp-host=BC:5F:F4:5C:7E:DF,10.10.1.23,hostnames
dhcp-host=34:D2:70:F8:F3:52,10.10.1.30,hostnames
dhcp-host=34:93:42:4E:13:30,10.10.1.31,hostnames
dhcp-host=34:93:42:4E:19:56,10.10.1.32,hostnames
dhcp-host=80:C5:F2:5D:D8:21,10.10.1.33,hostnames
dhcp-host=40:BD:32:88:C1:EA,10.10.1.34,hostnames
dhcp-host=74:C2:46:2D:DE:EF,10.10.1.40,hostnames
dhcp-host=B8:53:AC:86:B9:82,10.10.1.41,hostnames
dhcp-host=3C:28:6D:D1:40:47,10.10.1.42,hostnames
dhcp-host=44:80:EB:A5:9E:AB,10.10.1.43,hostnames
dhcp-host=F0:DB:E2:E4:07:9E,10.10.1.44,hostnames
dhcp-host=20:C9:D0:47:E3:2D,10.10.1.60,hostnames
dhcp-host=1C:1B:0D:9F:17:A6,10.10.1.62,hostnames
dhcp-host=84:38:35:5E:BD:DC,10.10.1.64,hostnames
dhcp-host=04:EA:56:65:71:6A,10.10.1.65,hostnames
dhcp-host=54:BF:64:22:EB:BB,10.10.1.63,hostnames
dhcp-host=00:11:32:20:A8:BC,10.10.1.250,hostnames
dhcp-host=00:11:32:A8:34:84,10.10.1.251,hostnames

Check the output of the commands I posted for the error which causes dnsmasq to fail.

Not seeing anything jump out at me.
I didnt even enable DHCP this time. simply manually added the entries into the file via nano.

Restarted the system and DNS/FTL is down. did the journalctl command and then cat’d the two logs.

This log should have entries from after i added the DHCP entries to the file as well as rebooting after removing the file again (which does allow DNS/FTL to show as enabled in the dashboard again)

Blockquote
cat /var/log/pihole-FTL.log
[2019-07-09 20:59:36.854 1062] Shutting down…
[2019-07-09 20:59:36.902 1062] Finished final database update
[2019-07-09 20:59:38.550 1062] ########## FTL terminated after 183030576.0 ms! ##########
[2019-07-09 21:00:12.287 547] Using log file /var/log/pihole-FTL.log
[2019-07-09 21:00:12.289 547] ########## FTL started! ##########
[2019-07-09 21:00:12.289 547] FTL branch: master
[2019-07-09 21:00:12.290 547] FTL version: v4.3.1
[2019-07-09 21:00:12.290 547] FTL commit: b60d63f
[2019-07-09 21:00:12.290 547] FTL date: 2019-05-25 21:37:26 +0200
[2019-07-09 21:00:12.291 547] FTL user: pihole
[2019-07-09 21:00:12.291 547] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2019-07-09 21:00:12.292 547] SOCKET_LISTENING: only local
[2019-07-09 21:00:12.292 547] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2019-07-09 21:00:12.292 547] MAXDBDAYS: max age for stored queries is 365 days
[2019-07-09 21:00:12.293 547] RESOLVE_IPV6: Resolve IPv6 addresses
[2019-07-09 21:00:12.293 547] RESOLVE_IPV4: Resolve IPv4 addresses
[2019-07-09 21:00:12.293 547] DBINTERVAL: saving to DB file every minute
[2019-07-09 21:00:12.294 547] DBFILE: Using /etc/pihole/pihole-FTL.db
[2019-07-09 21:00:12.294 547] MAXLOGAGE: Importing up to 24.0 hours of log data
[2019-07-09 21:00:12.295 547] PRIVACYLEVEL: Set to 0
[2019-07-09 21:00:12.295 547] IGNORE_LOCALHOST: Show queries from localhost
[2019-07-09 21:00:12.296 547] BLOCKINGMODE: Null IPs for blocked domains
[2019-07-09 21:00:12.296 547] ANALYZE_ONLY_A_AND_AAAA: Disabled. Analyzing all queries
[2019-07-09 21:00:12.296 547] DBIMPORT: Importing history from database
[2019-07-09 21:00:12.297 547] PIDFILE: Using /var/run/pihole-FTL.pid
[2019-07-09 21:00:12.297 547] PORTFILE: Using /var/run/pihole-FTL.port
[2019-07-09 21:00:12.298 547] SOCKETFILE: Using /var/run/pihole/FTL.sock
[2019-07-09 21:00:12.298 547] WHITELISTFILE: Using /etc/pihole/whitelist.txt
[2019-07-09 21:00:12.298 547] BLACKLISTFILE: Using /etc/pihole/black.list
[2019-07-09 21:00:12.299 547] GRAVITYFILE: Using /etc/pihole/gravity.list
[2019-07-09 21:00:12.299 547] REGEXLISTFILE: Using /etc/pihole/regex.list
[2019-07-09 21:00:12.299 547] SETUPVARSFILE: Using /etc/pihole/setupVars.conf
[2019-07-09 21:00:12.300 547] AUDITLISTFILE: Using /etc/pihole/auditlog.list
[2019-07-09 21:00:12.300 547] MACVENDORDB: Using /etc/pihole/macvendor.db
[2019-07-09 21:00:12.301 547] PARSE_ARP_CACHE: Active
[2019-07-09 21:00:12.302 547] Finished config file parsing
[2019-07-09 21:00:12.364 547] Database version is 3
[2019-07-09 21:00:12.365 547] Database successfully initialized
[2019-07-09 21:00:12.385 547] New forward server: 10.10.1.1 (0/512)
[2019-07-09 21:00:12.455 547] Resizing “/FTL-strings” from 4096 to 8192
[2019-07-09 21:00:12.467 547] Imported 2835 queries from the long-term database
[2019-07-09 21:00:12.468 547] -> Total DNS queries: 2835
[2019-07-09 21:00:12.468 547] -> Cached DNS queries: 86
[2019-07-09 21:00:12.469 547] -> Forwarded DNS queries: 2182
[2019-07-09 21:00:12.469 547] -> Exactly blocked DNS queries: 565
[2019-07-09 21:00:12.469 547] -> Unknown DNS queries: 2
[2019-07-09 21:00:12.470 547] -> Unique domains: 186
[2019-07-09 21:00:12.470 547] -> Unique clients: 7
[2019-07-09 21:00:12.470 547] -> Known forward destinations: 1
[2019-07-09 21:00:12.471 547] Successfully accessed setupVars.conf
[2019-07-09 21:00:12.535 549] PID of FTL process: 549
[2019-07-09 21:00:12.537 549] Listening on port 4711 for incoming IPv4 telnet connections
[2019-07-09 21:00:12.538 549] Listening on port 4711 for incoming IPv6 telnet connections
[2019-07-09 21:00:12.539 549] Listening on Unix socket
[2019-07-09 21:00:12.558 549] Received SIGHUP, reloading cache
[2019-07-09 21:00:12.559 549] Blocking status is enabled
[2019-07-09 21:00:12.560 549] INFO: No whitelist file found
[2019-07-09 21:00:12.560 549] Compiled 0 Regex filters and 0 whitelisted domains in 0.9 msec (0 errors)
[2019-07-09 21:00:17.089 549] /etc/pihole/gravity.list: parsed 114978 domains (took 4517.9 ms)
[2019-07-09 21:04:05.640 549] Shutting down…
[2019-07-09 21:04:05.653 549] Finished final database update
[2019-07-09 21:04:05.720 549] ########## FTL terminated after 233431.3 ms! ##########
[2019-07-09 21:04:39.748 515] Using log file /var/log/pihole-FTL.log
[2019-07-09 21:04:39.750 515] ########## FTL started! ##########
[2019-07-09 21:04:39.751 515] FTL branch: master
[2019-07-09 21:04:39.751 515] FTL version: v4.3.1
[2019-07-09 21:04:39.752 515] FTL commit: b60d63f
[2019-07-09 21:04:39.752 515] FTL date: 2019-05-25 21:37:26 +0200
[2019-07-09 21:04:39.752 515] FTL user: pihole
[2019-07-09 21:04:39.752 515] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2019-07-09 21:04:39.753 515] SOCKET_LISTENING: only local
[2019-07-09 21:04:39.753 515] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2019-07-09 21:04:39.754 515] MAXDBDAYS: max age for stored queries is 365 days
[2019-07-09 21:04:39.754 515] RESOLVE_IPV6: Resolve IPv6 addresses
[2019-07-09 21:04:39.754 515] RESOLVE_IPV4: Resolve IPv4 addresses
[2019-07-09 21:04:39.755 515] DBINTERVAL: saving to DB file every minute
[2019-07-09 21:04:39.755 515] DBFILE: Using /etc/pihole/pihole-FTL.db
[2019-07-09 21:04:39.756 515] MAXLOGAGE: Importing up to 24.0 hours of log data
[2019-07-09 21:04:39.756 515] PRIVACYLEVEL: Set to 0
[2019-07-09 21:04:39.757 515] IGNORE_LOCALHOST: Show queries from localhost
[2019-07-09 21:04:39.757 515] BLOCKINGMODE: Null IPs for blocked domains
[2019-07-09 21:04:39.757 515] ANALYZE_ONLY_A_AND_AAAA: Disabled. Analyzing all queries
[2019-07-09 21:04:39.758 515] DBIMPORT: Importing history from database
[2019-07-09 21:04:39.758 515] PIDFILE: Using /var/run/pihole-FTL.pid
[2019-07-09 21:04:39.758 515] PORTFILE: Using /var/run/pihole-FTL.port
[2019-07-09 21:04:39.759 515] SOCKETFILE: Using /var/run/pihole/FTL.sock
[2019-07-09 21:04:39.759 515] WHITELISTFILE: Using /etc/pihole/whitelist.txt
[2019-07-09 21:04:39.760 515] BLACKLISTFILE: Using /etc/pihole/black.list
[2019-07-09 21:04:39.760 515] GRAVITYFILE: Using /etc/pihole/gravity.list
[2019-07-09 21:04:39.760 515] REGEXLISTFILE: Using /etc/pihole/regex.list
[2019-07-09 21:04:39.761 515] SETUPVARSFILE: Using /etc/pihole/setupVars.conf
[2019-07-09 21:04:39.761 515] AUDITLISTFILE: Using /etc/pihole/auditlog.list
[2019-07-09 21:04:39.762 515] MACVENDORDB: Using /etc/pihole/macvendor.db
[2019-07-09 21:04:39.762 515] PARSE_ARP_CACHE: Active
[2019-07-09 21:04:39.763 515] Finished config file parsing
[2019-07-09 21:04:39.824 515] Database version is 3
[2019-07-09 21:04:39.826 515] Database successfully initialized
[2019-07-09 21:04:39.845 515] New forward server: 10.10.1.1 (0/512)
[2019-07-09 21:04:39.920 515] Resizing “/FTL-strings” from 4096 to 8192
[2019-07-09 21:04:39.934 515] Imported 2885 queries from the long-term database
[2019-07-09 21:04:39.941 515] -> Total DNS queries: 2885
[2019-07-09 21:04:39.942 515] -> Cached DNS queries: 94
[2019-07-09 21:04:39.942 515] -> Forwarded DNS queries: 2211
[2019-07-09 21:04:39.942 515] -> Exactly blocked DNS queries: 578
[2019-07-09 21:04:39.942 515] -> Unknown DNS queries: 2
[2019-07-09 21:04:39.943 515] -> Unique domains: 195
[2019-07-09 21:04:39.943 515] -> Unique clients: 7
[2019-07-09 21:04:39.943 515] -> Known forward destinations: 1
[2019-07-09 21:04:39.944 515] Successfully accessed setupVars.conf
[2019-07-09 21:04:40.003 517] PID of FTL process: 517
[2019-07-09 21:04:40.012 517] Listening on port 4711 for incoming IPv4 telnet connections
[2019-07-09 21:04:40.013 517] Listening on port 4711 for incoming IPv6 telnet connections
[2019-07-09 21:04:40.014 517] Listening on Unix socket
[2019-07-09 21:04:40.033 517] Received SIGHUP, reloading cache
[2019-07-09 21:04:40.034 517] Blocking status is enabled
[2019-07-09 21:04:40.035 517] INFO: No whitelist file found
[2019-07-09 21:04:40.035 517] Compiled 0 Regex filters and 0 whitelisted domains in 0.9 msec (0 errors)
[2019-07-09 21:04:44.207 517] /etc/pihole/gravity.list: parsed 114978 domains (took 4155.2 ms)

I cat’d the second log, but its got A LOT of stuff in it. Is there something in particular i should be looking for / grepping for?

what about sudo systemctl status pihole-FTL.service when the outage occurs ?

ok … so mega weird. I copied the 04 conf file back to the /etc/dnsmasq.d/ directory and … everything is working now? I’ve now disabled dhcp on my DDWRT router. Added the piholes IP as the first entry to the DNS order (in DDWRT) and kept the DDWRT routers IP as the dns server under setup.

I had some dnsmasq entries to forward certain hostnames on my domain to local IP’s such as my router and my two NAS’s, but that no longer works. I’ve added them into the /etc/hosts files on the pihole but i’m assuming i’ll need to replicate the additional dnsmasq options I had on the DDWRT router somewhere within pihole? I guess I should start a new thread.

If the issue re-surfaces, run the command above and it will tell you where the error is …

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.