DNS startet nicht nach Update auf 4.2.1


#1

Hallo zusammen,

nach dem Update auf 4.2.1 startet der DNS-Dienst nicht mehr.
Beim manuellen Starten wird folgender Fehler angezeigt:
dnsmasq: bad option at line 44 of /etc/dnsmasq.d/01-pihole.conf

Die entsprechende Zeile lautet:
dhcp-name-match=set:wpad-ignore,wpad

Wenn ich die Zeile auskommentiere startet der Dienst korrekt.

Ein anderer DNS-Dienst läuft nicht …

Kann es Probleme geben wenn die Zeile auskommentiert bleibt ?
Wie kann das Problem behoben werden ?

Vielen Dank im Voraus


Error restarting dnsmasq.d
#2

Auf meinem System startet alles wunderbar. Bei mir ist ebenfalls v4.2.1 installiert, und in der Datei 01-pihole.conf gibt es bei mir die genannte Zeile auch. Der Eintrag soll auch existieren, er dient dazu eine Sicherheitslücke zu schließen.

Was ist denn die Ausgabe des Kommandos

pihole-FTL version


#3

Die Ausgabe sieht folgendermassen aus:
vDev-3e40158


#4

Ok, da stimmt bei dir etwas nicht. Eigentlich sollte die Ausgabe “v4.2.1” sein.

Also wenn es meine Installation wäre, würde ich folgendes versuchen

pihole checkout master

und danach

pihole updatePihole


#6

“pihole checkout master” hab ich schon gemacht …

Hier nochmal die Ausgabe:

[root@pihole ~]# pihole checkout master
Please note that changing branches severely alters your Pi-hole subsystems
Features that work on the master branch, may not on a development branch
This feature is NOT supported unless a Pi-hole developer explicitly asks!
Have you read and understood this? [y/N] y

[i] Shortcut “master” detected - checking out master branches…
[i] Pi-hole core
[✓] Switching to branch: ‘master’ from ‘refs/heads/master’
[i] Already up-to-date.
[i] Web interface
[✓] Switching to branch: ‘master’ from ‘refs/heads/master’
[i] Already up-to-date.
[i] Detecting architecture…[root@pihole ~]#
[root@pihole ~]#
[root@pihole ~]# pihole updatePihole
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] Web Interface: up to date
[i] FTL: up to date

[✓] Everything is up to date!
[root@pihole ~]#

Also keine Updates vorhanden :frowning:


#7

Please generate and upload a debug log and post the token.


#8

The debug token is “reo4hou6d0”


#9

For your info:
The debug runs without line 44 (dhcp-name-match=set:wpad-ignore,wpad)


#10

Take a look at Error restarting dnsmasq.d


#11

Okay … but how I can update to 4.2.1 ?


#12

The output of pihole -v says:

[root@pihole ~]# pihole -v
Pi-hole version is v4.2.1 (Latest: v4.2.1)
AdminLTE version is v4.2 (Latest: v4.2)
FTL version is vDev-3e40158 (Latest: v4.2.1)

So FTL version seems to be 4.2.1 …


#13

Versuche mal nach einer erneute update Frage
Ein Reboot auszuführen!

Und dan schaue nochmal Status usw.


#14

ALso ganz normal “pihole -up” und dann das OS rebooten ?


#15

Ja genau

Ich hätte das vorhin auch er sagte es wären ups
Da ich habe es ausgeführt aber nichts

Dan ein Neustart wieder ausgeführt alles top!


#16

Okay, nochmal ein Update gemacht und nach dem Reboot diselbe Situation:
[root@pihole ~]# pihole -v
Pi-hole version is v4.2.1 (Latest: v4.2.1)
AdminLTE version is v4.2 (Latest: v4.2)
FTL version is vDev-3e40158 (Latest: v4.2.1)

Sagt auch immer noch dass alles up to date ist:

[root@pihole ~]# pihole -up
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] Web Interface: up to date
[i] FTL: up to date

[✓] Everything is up to date!


#17

Eigentlich sollte dort dies stehen:

FTL version is v4.2.1 (Latest: v4.2.1)

Warum auch immer ist bei dir eine Entwicklungsversion im Einsatz, und nicht die Releaseversion.


#18

Wahrscheinlich weil ich mal auf “checkout dev” war …
Aber nach switch auf “checkout master” sollte er doch die entsprechende Version installieren …
Das tut er aber offensichtlich nicht …
Gibt es ne Möglichkeit nur das FTL zu deinstallieren und neu einzuspielen ?


#19

rip-update

Ich denke er hat diesen Befehl ausgeführt
Den dan passiert das


#20

Nee, der Befehl ist mir völlig unbekannt und auch nicht in der History zu finden …


#21

Mit dem Befehl sehr vorsichtig umgehen!

Ja dan