DNS set up question: Custom IPv4 and IPv6 addresses.


Hello, there I am a new user of pihole and have a few questions. First off how can I direct my devices to use my DNS server that’s running on pihole? I followed the instructions from this link https://docs.pi-hole.net/guides/unbound/ but it does not mention an IPv6 upstream DNS server. As per the rest of the setup, I disabled DHCP on my router and I have the DNS server (IPv4) set to the IP address I assigned to pihole.

I set the custom ipv4 address to the address shown on that guide, however, If I have my IP address set as for example for my pihole should that address be the one listed on the guide or the one from my actual IP?

Is there a way to double check that my devices are using my Pihole DNS server?

Lastly, is there any performance tweaks I could set for the unbount script? I am running it on a odroid xu4.



Enter this in Custom 3 (IPv6) on Pi-Hole Admin GUI > Settings > DNS. This is the loopback IPv6 address for unbound.


Your clients should all be directed to use Pi-Hole at the IP assigned to the Pi-Hole on your network, in this case

Pi-Hole, in turn, sends it’s upstream DNS server traffic to unbound running on IP on the Pi (the loopback or internal address).

The flowpath should be client > Pi-Hole > unbound > Pi-Hole > client.

The clients are unaware of which upstream DNS server Pi-Hole is using. From their perspective, they communicate only with Pi-Hole and the traffic to unbound is handled by Pi-Hole and is invisible to the clients.



Perfect i will make that edit. If I want to tell my router to make sure it uses the pihole setup for IPv6 DNS do i just add the inet6 (via ifconfig) to the IPv6 DNS server on my router? Once that is set up how can I test to make sure the network are using those DNS servers and not the ISP’s.




Run an nslookup or dig command from a client, and if the server that replies is Pi-Hole then Pi-Hole is handling DNS requests.


closed #5

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.